Updated to latest version and hit with this error. (pasted below)

Could anyone offer advice on how to fix this or revert back a version?

Entry “Piwik\Plugins\TagManager\Model\Container” cannot be resolved: Entry “Piwik\Plugins\TagManager\Model\Environment” cannot be resolved: Entry “Piwik\Plugins\TagManager\SystemSettings” cannot be resolved: Entry “Piwik\Concurrency\Lock” cannot be resolved: Entry “Piwik\Concurrency\LockBackend” cannot be resolved: the class is not instantiableFull definition:Object ( class = #NOT INSTANTIABLE# Piwik\Concurrency\LockBackend scope = singleton lazy = false)Full definition:Object ( class = Piwik\Concurrency\Lock scope = singleton lazy = false __construct( $backend = get(Piwik\Concurrency\LockBackend) $lockKeyStart = #UNDEFINED# $defaultTtl = (default value) NULL ))Full definition:Object ( class = Piwik\Plugins\TagManager\SystemSettings scope = singleton lazy = false __construct( ))Full definition:Object ( class = Piwik\Plugins\TagManager\Model\Environment scope = singleton lazy = false __construct( $settings = get(Piwik\Plugins\TagManager\SystemSettings) ))Full definition:Object ( class = Piwik\Plugins\TagManager\Model\Container scope = singleton lazy = false __construct( $containersDao = get(Piwik\Plugins\TagManager\Dao\ContainersDao) $containerVersionsDao = get(Piwik\Plugins\TagManager\Dao\ContainerVersionsDao) $containerPublishesDao = get(Piwik\Plugins\TagManager\Dao\ContainerReleaseDao) $contextProvider = get(Piwik\Plugins\TagManager\Context\ContextProvider) $containerIdGenerator = get(Piwik\Plugins\TagManager\Model\Container\ContainerIdGenerator) $environment = get(Piwik\Plugins\TagManager\Model\Environment) ))

I have exactly the same error, no idea how to fix it.

Did you just update today too? @SilviuDan

If by chance you get a solution, would you mind updating me with some help?

Yes, I updated today. Seems the issue existed before as I dag through old github threads. I will open a ticket on github.

Thsank you @SilviuDan good luck. :slight_smile:

It sounds like the config/global.php file was not updated properly during the update. You can replace it with https://raw.githubusercontent.com/matomo-org/matomo/3.x-dev/config/global.php or perform the manual three step update: Update Piwik User Guide - Analytics Platform - Matomo (this will ensure every file is correct).

I justed ended up reinstalling matomo after I backuped my config file.