Update to 2.16.0 - The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig" at line 7


(Garvin) #1

Hi!

After upgrading from 2.15.0 to 2.16.0 viewing a segment report comes up with:

The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig" at line 7.

There are several reports that use umlauts. They worked just the same in 2.15.0, and in the normal backend they show up without a problem in dropdowns.

What’s happening? Googled a bit, found to insert ‘charset = “utf8”’ to config.ini.php but that doesn’t change anything.

I don’t know Twig, how can I debug exactly what UTF-8 string is making trouble here?!


(Matthieu Aubry) #2

Hi there,

can you please post your report in the existing issue @ The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig". · Issue #4410 · matomo-org/piwik · GitHub ?


(Garvin) #3

Just did that, but the thread seems odd (I saw it before), since it only stopped working after the upgrade from 2.15 to 2.16 :frowning: