Update from 1.10.0 to 2.10.0 and can't login


#1

I apologize but I have searched on this forum and on the internet for hours with no more ideas.

As the title says I updated my 1.10.0 installation to 2.10.0.
Actually I think I AM getting logged in but I get this error.

“The requested website idSite is not found in the request, or is invalid. Please check that you are logged in Piwik and have permission to access the specified website.”

Here are things I have done.

  1. The reason I say I am getting logged in is because if I give piwik another un or pw I get the incorrect un/pw error.
  2. I DID save the config.ini.php file and upload it.
  3. The first time I ftp’d the exploded files up to the server I got a 500 error.
  4. I deleted the piwik install and ftp’d the new install up to the server. Then I got the error shown above.
  5. Deleted the install again. uploaded the zip file using cpanel file manager.
  6. Unzipped it on the server & uploaded the config.ini.php file again. Same error.
  7. Ask for a new password at login and gave it to piwik. It sent the confirmation. I confirmed email. Login…same error.
  8. Research online made me go check the mysql database for errors. It was fine.
  9. I found that the username_defaultReport value is set to 1 in the Mysql database for piwik in the options table.

The error log on the piwik root directory is as shown above.
The server log doesn’t show errors except for a favicon related to piwik, robots.txt missing and 404 page missing.

Any ideas what to check now?
Doggone it … this was working before I “fixed” it. :slight_smile:

Rex


(Matthieu Aubry) #2

Hi there,

  1. what is the URL after you login?

  2. Do you have in your database a site for this ‘idSite’ parameter in this URL?

  3. could you try the latest piwik beta? http://builds.piwik.org/


#3

Hi Matt,

Thanks for the suggestions and quesitons. I don’t know the answers to #1 & #2.

And now…

I wasn’t sure I was gonna get an answer and was in the middle of some facebook ads so I needed to get up and running, so I decided to just blow away the multiple years worth of data and created a new install.

It is now up and running fine.

So at this time I guess I will just go forward from here. I have about 20 websites I need to go put piwik tracking back on and so one but what is done is done. As I said I needed to get my tracking going because of paid ads running.

Thanks for coming back.

Rex