Update Fehlermeldungen


#1

Hallo,
bis jetzt hatte ich noch keine Schwierigkeiten beim updaten, bis heute:
Schon x-mal versucht: Upload, tmp auf 777 und dann entweder leere Seite, oder Fehler in coreupdater usw. Immer was anderes, obwohl die Daten gleich sein -müssten- .
Jetzt nach meinem letzten Versuch folgender Fehler:

There is an error. Please report the message and full backtrace in the Piwik forums.

Warning: include(HTML/QuickForm2/Rule/Required.php) [function.include]: failed to open stream: Datei oder Verzeichnis nicht gefunden in /is/htdocs…/piwik/libs/HTML/QuickForm2/Loader.php on line 84

Backtrace -->
#0 Piwik_ErrorHandler(2, include(HTML/QuickForm2/Rule/Required.php) [function.include]: failed to open stream: Datei oder Verzeichnis nicht gefunden, /is/htdocs/…/piwik/libs/HTML/QuickForm2/Loader.php, 84, Array ([className] => HTML_QuickForm2_Rule_Required,[includeFile] => HTML/QuickForm2/Rule/Required.php)) called at [(null):0]#1 HTML_QuickForm2_Loader::loadClass() called at [/is/htdocs/…/piwik/libs/HTML/QuickForm2/Loader.php:84]#2 HTML_QuickForm2_Loader::loadClass(HTML_QuickForm2_Rule_Required, ) called at [/is/htdocs/…/piwik/libs/HTML/QuickForm2/Factory.php:224]#3 HTML_QuickForm2_Factory::createRule(required, HTML_QuickForm2_Element_InputText Object ([] => Array ([type] => text,[name] => form_login,[id] => form_login-0),[] => Array ([0] => id,[1] => name,[2] => type),[] => ,[] => ,[] => Piwik_Login_FormLogin Object ([] => Array ([0] => form_login),[] => Array (),[] => Array ([0] => id,[1] => method),[] => Array ([0] => HTML_QuickForm2_Element_InputText Object ( RECURSION),[] => ,[] => ,[] => ,[] => Array (),[] => Array (),[] => Array (),[] => ,[] => Array ([action] => ,[name] => loginform,[id] => loginform,[method] => post),[] => 0,[] => ),[] => Array (),[] => Array (),[] => Array (),[] => ,[] => 0,[] => ), Benutzername benötigt, ) called at [/is/htdocs/…/piwik/libs/HTML/QuickForm2/Node.php:507]#4 HTML_QuickForm2_Node->addRule(required, Benutzername benötigt) called at [/is/htdocs/…e/piwik/plugins/Login/FormLogin.php:27]#5 Piwik_Login_FormLogin->init() called at [/is/htdocs/…/piwik/core/QuickForm2.php:38]#6 Piwik_QuickForm2->__construct(loginform, post, , ) called at [/is/htdocs/…/piwik/plugins/Login/FormLogin.php:21]#7 Piwik_Login_FormLogin->__construct() called at [/is/htdocs/…/piwik/plugins/Login/Controller.php:42]#8 Piwik_Login_Controller->login() called at [/is/htdocs/…/piwik/plugins/Login/Controller.php:28]#9 Piwik_Login_Controller->index() called at [(null):0]#10 call_user_func_array(Array ([0] => Piwik_Login_Controller Object ([] => Login,[] => ,[] => ,[] => 0,[] => ),[1] => index), Array ()) called at [/is/htdocs/…/piwik/core/FrontController.php:125]#11 Piwik_FrontController->dispatch(Login, ) called at [/is/htdocs…/piwik/core/Controller.php:434]#12 Piwik_Controller->redirectToIndex(CoreHome, index) called at [/is/htdocs…/piwik/plugins/CoreHome/Controller.php:41]#13 Piwik_CoreHome_Controller->redirectToCoreHomeIndex() called at [(null):0]#14 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => ,[] => ,[] => 0,[] => ),[1] => redirectToCoreHomeIndex), Array ()) called at [/is/htdocs/…/piwik/core/FrontController.php:125]#15 Piwik_FrontController->dispatch() called at [/is/htdocs/…e/piwik/index.php:60]

There is an error. Please report the message and full backtrace in the Piwik forums.

Warning: include(HTML/QuickForm2/Rule/Required.php) [function.include]: failed to open stream: Datei oder Verzeichnis nicht gefunden in /is/htdocs/…/piwik/libs/HTML/QuickForm2/Loader.php on line 84

Backtrace -->
#0 Piwik_ErrorHandler(2, include(HTML/QuickForm2/Rule/Required.php) [function.include]: failed to open stream: Datei oder Verzeichnis nicht gefunden, /is/htdocs/…e/piwik/libs/HTML/QuickForm2/Loader.php, 84, Array ([className] => HTML_QuickForm2_Rule_Required,[includeFile] => HTML/QuickForm2/Rule/Required.php)) called at [(null):0]#1 HTML_QuickForm2_Loader::loadClass() called at [/is/htdocs/…/piwik/libs/HTML/QuickForm2/Loader.php:84]#2 HTML_QuickForm2_Loader::loadClass(HTML_QuickForm2_Rule_Required, ) called at [/is/htdocs…/piwik/libs/HTML/QuickForm2/Factory.php:224]#3 HTML_QuickForm2_Factory::createRule(required, HTML_QuickForm2_Element_InputText Object ([] => Array ([type] => text,[name] => form_login,[id] => form_login-0),[] => Array ([0] => id,[1] => name,[2] => type),[] => ,[] => ,[] => Piwik_Login_FormLogin Object ([] => Array ([0] => form_login),[] => Array (),[] => Array ([0] => id,[1] => method),[] => Array ([0] => HTML_QuickForm2_Element_InputText Object ( RECURSION),[] => ,[] => ,[] => ,[] => Array (),[] => Array (),[] => Array (),[] => ,[] => Array ([action] => ,[name] => loginform,[id] => loginform,[method] => post),[] => 0,[] => ),[] => Array (),[] => Array (),[] => Array (),[] => ,[] => 0,[] => ), Benutzername benötigt, ) called at [/is/htdocs/…/piwik/libs/HTML/QuickForm2/Node.php:507]#4 HTML_QuickForm2_Node->addRule(required, Benutzername benötigt) called at [/is/htdocs…/piwik/plugins/Login/FormLogin.php:27]#5 Piwik_Login_FormLogin->init() called at [/is/htdocs/…/piwik/core/QuickForm2.php:38]#6 Piwik_QuickForm2->__construct(loginform, post, , ) called at [/is/htdocs/…/piwik/plugins/Login/FormLogin.php:21]#7 Piwik_Login_FormLogin->__construct() called at [/is/htdocs/…/piwik/plugins/Login/Controller.php:42]#8 Piwik_Login_Controller->login() called at [/is/htdocs…e/piwik/plugins/Login/Controller.php:28]#9 Piwik_Login_Controller->index() called at [(null):0]#10 call_user_func_array(Array ([0] => Piwik_Login_Controller Object ([] => Login,[] => ,[] => ,[] => 0,[] => ),[1] => index), Array ()) called at [/is/htdocs/…/piwik/core/FrontController.php:125]#11 Piwik_FrontController->dispatch(Login, ) called at [/is/htdocs/…/piwik/core/Controller.php:434]#12 Piwik_Controller->redirectToIndex(CoreHome, index) called at [/is/htdocs/…/piwik/plugins/CoreHome/Controller.php:41]#13 Piwik_CoreHome_Controller->redirectToCoreHomeIndex() called at [(null):0]#14 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => ,[] => ,[] => 0,[] => ),[1] => redirectToCoreHomeIndex), Array ()) called at [/is/htdocs/…/piwik/core/FrontController.php:125]#15 Piwik_FrontController->dispatch() called at [/is/htdocs/…/piwik/index.php:60]

There is an error. Please report the message and full backtrace in the Piwik forums.

Warning: include() [function.include]: Failed opening ‘HTML/QuickForm2/Rule/Required.php’ for inclusion (include_path=’.:/usr/share/pear/php5’) in /is/htdocs/…e/piwik/libs/HTML/QuickForm2/Loader.php on line 84

Backtrace -->
#0 Piwik_ErrorHandler(2, include() [function.include]: Failed opening ‘HTML/QuickForm2/Rule/Required.php’ for inclusion (include_path=’.:/usr/share/pear/php5’), /is/htdoc…/piwik/libs/HTML/QuickForm2/Loader.php, 84, Array ([className] => HTML_QuickForm2_Rule_Required,[includeFile] => HTML/QuickForm2/Rule/Required.php)) called at [(null):0]#1 HTML_QuickForm2_Loader::loadClass() called at [/is/htdocs/…/piwik/libs/HTML/QuickForm2/Loader.php:84]#2 HTML_QuickForm2_Loader::loadClass(HTML_QuickForm2_Rule_Required, ) called at [/is/htdocs/…e/piwik/libs/HTML/QuickForm2/Factory.php:224]#3 HTML_QuickForm2_Factory::createRule(required, HTML_QuickForm2_Element_InputText Object ([] => Array ([type] => text,[name] => form_login,[id] => form_login-0),[] => Array ([0] => id,[1] => name,[2] => type),[] => ,[] => ,[] => Piwik_Login_FormLogin Object ([] => Array ([0] => form_login),[] => Array (),[] => Array ([0] => id,[1] => method),[] => Array ([0] => HTML_QuickForm2_Element_InputText Object ( RECURSION),[] => ,[] => ,[] => ,[] => Array (),[] => Array (),[] => Array (),[] => ,[] => Array ([action] => ,[name] => loginform,[id] => loginform,[method] => post),[] => 0,[] => ),[] => Array (),[] => Array (),[] => Array (),[] => ,[] => 0,[] => ), Benutzername benötigt, ) called at [/is/htdocs…/piwik/libs/HTML/QuickForm2/Node.php:507]#4 HTML_QuickForm2_Node->addRule(required, Benutzername benötigt) called at [/is/htdocs/…/piwik/plugins/Login/FormLogin.php:27]#5 Piwik_Login_FormLogin->init() called at [/is/htdocs/…/piwik/core/QuickForm2.php:38]#6 Piwik_QuickForm2->__construct(loginform, post, , ) called at [/is/htdocs/…/piwik/plugins/Login/FormLogin.php:21]#7 Piwik_Login_FormLogin->__construct() called at [/is/htdocs…/piwik/plugins/Login/Controller.php:42]#8 Piwik_Login_Controller->login() called at [/is/htdocs/…/piwik/plugins/Login/Controller.php:28]#9 Piwik_Login_Controller->index() called at [(null):0]#10 call_user_func_array(Array ([0] => Piwik_Login_Controller Object ([] => Login,[] => ,[] => ,[] => 0,[] => ),[1] => index), Array ()) called at [/is/htdocs/…/piwik/core/FrontController.php:125]#11 Piwik_FrontController->dispatch(Login, ) called at [/is/htdocs/…/piwik/core/Controller.php:434]#12 Piwik_Controller->redirectToIndex(CoreHome, index) called at [/is/htdocs/…/piwik/plugins/CoreHome/Controller.php:41]#13 Piwik_CoreHome_Controller->redirectToCoreHomeIndex() called at [(null):0]#14 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => ,[] => ,[] => 0,[] => ),[1] => redirectToCoreHomeIndex), Array ()) called at [/is/htdocs/…piwik/core/FrontController.php:125]#15 Piwik_FrontController->dispatch() called at [/is/htdocs/…/piwik/index.php:60]

Auch schon Caches und Cookies gelöscht, nützt nichts! Leider habe ich die Version 1.1 nicht mehr!:S, die hat aber funktioniert, kann ich die noch mal irgendwo downloaden?
Schon mal danke im Voraus.


(Jens) #2

Schau doch bitte mal nach, ob bei Dir die Datei /libs/HTML/QuickForm2/Rule/Required.php vorhanden ist.

Hast Du ein Update in ein bestehendes oder ein neues, leeres Verzeichnis gemacht?

Gruß,
Jens


#3

Hallo Jens,
die Datei ist da und das Upload habe ich in ein leeres Verzeichnis gemacht! Die Fehlermeldungen sagen immer, eine Datei fehlt, die ist aber immer da.
Vor kurzem hatte ich das Problem mit Wordpress. Da hatte ich in einem Forum gelesen, man sollte einfach alles nochmal hochladen. Nach mehrmaligen Versuch hatte ich Glück. Deshalb war das auch bei Piwik meine Idee. Leider ohne Erfolg.
Ich benutze Transmit 4.1.4 und einen Mac…


(Jens) #4

Hmm, da kann ich mir dann auch keinen richtigen Reim drauf bilden.

Bei welchem Webhoster liegt die Seite, unter der Du Piwik installieren möchtest?

Gruß,
Jens


#5

Host Europe


(Jens) #6

Hast Du beim dortigen Support schon mal gefragt?
Mir fällt sonst auch nichts mehr ein …


#7

Es war wohl wie bei Wordpress.
Kein Fehler zu entdecken, zusammen mit dem Support von Host Europe gesucht. Alle Dateien vorhanden.
Ich habe den Mitarbeiter gebeten von seinem PC, Piwik nochmal hochzuladen.
Und siehe da alles funktioniert! (:smiley:
Warum kann ich mir allerdings nicht erklären, auch egal…