Update auf 1.5.1 JavaScript-Problem


#1

Beim Update von 1.5 auf 1.5.1 habe ich anhaltend folgenden Fehler, bei der Übersichtsseite wird wenig angezeigt. Oben die Menüreihen gehen, darunter die “Widgets” sind nicht sichtbar. Klicke ich auf die Auswahl der Websiten rechts oben, dann kommt das dropdown-Menü, aber ich kann darauf nichts auswählen.

Sieht nach einen JavaScript-Problem aus, ich nutze FF3.6.18 unter Win2000.

Eine Idee, was das sein kann, welche Datei ich ggf. noch mal hochladen muß?


#2

Ich merke grade im nicht angezeitgen Quelltext, dass dort folgendes auf der Titelseite steht:

Lade Daten …
Einen Moment bitte. Wir laden die erforderlichen Daten. Bitte neu laden, falls längere Zeit keine Aktion ausgeführt wird.

Neu laden hilft natürlich nicht, es hängt.


#3

Ich versuche mal stückchenweise weiterzukommen. Mittlerweile habe ich versucht wieder auf 1.5 zurückzugehen. Leider habe ich da genau dasselbe Problem.

Im cache finde ich 3 Dateien. Kann man daraus eine Schlußfolgerung ziehen?
ie6.tpl, login.tpl, header.tpl. Ich benutze nicht IE6 sondern FF3.6.18


#4

Sehe grade, das ist eine ähnliche Frage: 301 Moved Permanently

Die Antwort war, dass man das Verzeichnis TMP löschen soll. Liegt das am Cache oder was? Wie soll ich das löschen, darauf habe ich keine Berechtigung?


(Peterbo) #5

Beim Hoster anfragen, ob er das Verzeichnis dem FTP-Benutzer zuordnet und chmod 777 dafür vergeben kann.


#6

Ja, das war tatsächlich die Lösung. Ist aber ein wirklich blödes Problem innerhalb von PIWIK.

Bei all-inkl. gibt es für solche Sonderfälle sogar eine Anleitung:
all-inkl