Update 2.5 to 2.7 fails becaue PHP


#1

Hi,

after autoupdating I have login page with the following text:

To run Piwik you need at least PHP version 5.3.3
Unfortunately it seems your webserver is using PHP version 5.3.2-1ubuntu4.27.
Please try to update your PHP version, Piwik is really worth it! Nowadays most web hosts support PHP 5.3.3.
Also see the FAQ: My Web host supports PHP4 by default. How can I enable PHP5?

I can’t login anymore. For several reasons I can not update PHP to 5.3.3. How can I go back to 2.5 ?
BTW: would it not be better to check this before the update :frowning:

Hans


#2

Hello Hans,

You may download older releases of Piwik from Releases · matomo-org/matomo · GitHub
Be sure to backup your config.ini.php file before downgrading piwik, you may follow these steps Update Piwik - Analytics Platform - Matomo


(Matthieu Aubry) #3

Download older releases from: http://builds.piwik.org/

but please upgrade your PHP it’s very important for speed + security! see: Announcing Piwik will end PHP 5.3 support in 2016 - Analytics Platform - Matomo