Update 2.5.0 and no logging at all


#1

Hi all,

updated my Piwik 2.4.1 to 2.5.0 through the Auto Updating Feature.
Realized after some days that nothing has been logged since the update, not visit in DB, not DB entry at all.
Checked the tracking pixel, also not served a 1px graphics anymore, but also no error messages.
Checked this forums, seen that many have problems with 2.5.0, tried the rollback with


UPDATE `piwik_option` SET option_value = "2.4.1" WHERE option_name = "version_core";

and than i runned the automatic database updates again.
All working now.

I never had any issues with the auto updater, weird thing.

This post should be just for information and for help, it’s solved for me.


#2

I have the same problem. I have tried the process describted above. Rollback and run the automatic database update again. But without success. My websites will still not be tracked.

Any ideas what I could do else to get it working?


#3

Same here… No more logging since update

Additional:

I wanted to check my Version Number but somehow I get only an Errormessage:
Fatal error: Class ‘Piwik_Plugin’ not found in /home/XXXXXXX/public_html/analytics/plugins/ExampleUI/ExampleUI.php on line 27

I checked a redownloaded piwik Install and there is also not such a file, but decided to reupload the whole Plugin folder.

Did someone else encountered that Problem? I couldn’t find anything, just a topic from 2011 that properbly won’t be connected to this issue now.

If yes and you could fix it, please tell me how to do so… I will try to investigate if i can find a solution… but i have really no clue about php, so that should be hard to do…

Kindly
Sascha


#4

Okay,
the settings Problem could be solved with this one: 301 Moved Permanently

But the ‘not’ counting Problem i couldn’t solve till now… :frowning:

Edit: After being able to open the Setting, i can confirm it is Piwik 2.5.0.


#5

What is most irritating… I have a SECONDARY/THIRD Install on the same Server, only different Domain and both are working just fine (after Update) to 2.5.0 … couldn’t fine anything other than the domain that would be different, but again, i have no PHP Scripting knowledge at all :frowning:

Edit: have now tried a second time the advice from “brainfoolong” and it SEEMS that it has no effect. Maybe it still needs time… but it was done more than an hour ago and there should be at least something … there are 100+ active Sites … and all 0 Visits the last days.


(Matthieu Aubry) #6

If you have an issue with 2.5.0 that is still not solved, please

  1. check your server error log -> is there an error there?
  2. check your Visitors> Visitor log -> is there new data there or really NO data?

Let me know here, we can help getting this issue resolved!


#7

I did some further investigations.

When I switch to generating the reports by accessing the reports in the settings, the visitors will be counted.
So there is no data loss. It seems that the counting works, but generating the reports does not work.

When I switch back to generating the reports by cron, the visitors will not be counted again.
I use the web cron functionality. The cron runs every hour. The database has 150 MB.

Even if I access the webcron-url by browser the reports will not be generated.
That is why I assume the error belongs to piwik, not the webhosting cron itself.

So I think this problem is related to the webcron function.
Does anybody have further ideas to get it working?


(Matthieu Aubry) #8

Can you try to call the Web Cron: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

is there any error in the output?


#9

When I run the web cron, I receive only a blank page without any content.
url/misc/cron/archive.php?token_auth=KEY


#10

Today checking if it is counting after the Reroll I came back here and wanted to seach the

to generating the reports by accessing the reports in the settings, the visitors will be counted

Part i found my Piwik telling me

Warnung: Folgende Plugins sind nicht kompatibel mit Piwik 2.5.0 und konnten nicht geladen werden: Referers, PDFReports
(Translated roughly to: Warning: The following plugins are incompatible with Piwik 2.5.0 and coun’t be loaded: Referers, PDFReports)
You can update or uninstall these plugins on the Manage Plugins page.

I checked my Plugins (where i personally never added one, kept it mostly like its delivered) i found that one more would be incompatible:
ExampleFeedburner, SecurityInfo, VisitorGenerator, Referers, PDFReports
While the first three are (for me) inimportant, could play the last two a part in the problem? They are all nor inavtive, no idea if one was active before, but for sure now no more.

Now comes the 3MB Errorlog… Well, cutted to smaller pieces and most duplicates deleted. Mayor flaw (not enough connections seems to be a real problem -.- … again)

[16-Oct-2012 07:07:43] PHP Notice: Undefined index: sitesearch in /home/XXX/public_html/analytics/plugins/SitesManager/SitesManager.php on line 89
[16-Oct-2012 07:07:43] PHP Notice: Undefined index: sitesearch_keyword_parameters in /home/XXX/public_html/analytics/plugins/SitesManager/SitesManager.php on line 96
[16-Oct-2012 07:07:43] PHP Notice: Undefined index: sitesearch_category_parameters in /home/XXX/public_html/analytics/plugins/SitesManager/SitesManager.php on line 105

[09-Mar-2013 00:08:53] PHP Notice: Undefined index: keep_url_fragment in /home/XXX/public_html/analytics/plugins/SitesManager/SitesManager.php on line 107
[09-Mar-2013 00:08:53] PHP Notice: Undefined index: keep_url_fragment in /home/XXX/public_html/analytics/plugins/SitesManager/SitesManager.php on line 111

[09-Jul-2014 03:30:14 UTC] PHP Fatal error: require_once(): Failed opening required ‘/home/XXX/public_html/analytics/…/…/autoload.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/XXX/public_html/analytics/piwik.php on line 48
[09-Jul-2014 04:18:57 UTC] PHP Warning: require(/home/XXX/public_html/analytics/vendor/mustangostang/spyc/Spyc.php): failed to open stream: No such file or directory in /home/XXX/public_html/analytics/vendor/composer/autoload_real.php on line 58
[09-Jul-2014 04:18:57 UTC] PHP Fatal error: require(): Failed opening required ‘/home/XXX/public_html/analytics/vendor/mustangostang/spyc/Spyc.php’ (include_path=’/home/XXX/public_html/analytics/vendor/phpunit/php-token-stream:/home/XXX/public_html/analytics/vendor/phpunit/php-text-template:/home/XXX/public_html/analytics/vendor/phpunit/phpunit-mock-objects:/home/XXX/public_html/analytics/vendor/phpunit/php-timer:/home/XXX/public_html/analytics/vendor/phpunit/php-file-iterator:/home/XXX/public_html/analytics/vendor/phpunit/php-code-coverage:/home/XXX/public_html/analytics/vendor/phpunit/phpunit:/home/XXX/public_html/analytics/vendor/symfony/yaml:.:/usr/lib/php:/usr/local/lib/php’) in /home/XXX/public_html/analytics/vendor/composer/autoload_real.php on line 58
[09-Jul-2014 04:20:34 UTC] PHP Notice: Undefined variable: matches in /home/XXX/public_html/analytics/vendor/piwik/device-detector/Parser/Client/MediaPlayer.php on line 47
[09-Jul-2014 04:20:34 UTC] PHP Warning: Illegal string offset ‘regex’ in /home/XXX/public_html/analytics/vendor/piwik/device-detector/Parser/ParserAbstract.php on line 243
[09-Jul-2014 04:20:34 UTC] PHP Warning: Illegal string offset ‘regex’ in /home/XXX/public_html/analytics/vendor/piwik/device-detector/Parser/Device/DeviceParserAbstract.php on line 315
[09-Jul-2014 05:25:43 UTC] PHP Warning: mysqli_connect(): (42000/1203): User web2_web2 already has more than ‘max_user_connections’ active connections in /home/XXX/public_html/analytics/core/Tracker/Db/Mysqli.php on line 77

[14-Aug-2014 09:55:33 UTC] PHP Warning: mysqli_connect(): (HY000/2002): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2) in /home/XXX/public_html/analytics/core/Tracker/Db/Mysqli.php on line 77

[16-Aug-2014 09:43:39 UTC] PHP Fatal error: Class ‘Piwik\Development’ not found in /home/XXX/public_html/analytics/core/Cache/PersistentCache.php on line 94
[16-Aug-2014 13:19:12 UTC] Error in Piwik (tracker): An unexpected website was found, check idSite in the request.

[17-Aug-2014 07:02:48 UTC] Error in Piwik (tracker): User web2_web2 already has more than ‘max_user_connections’ active connections
[17-Aug-2014 08:00:35 UTC] Error in Piwik (tracker): An unexpected website was found, check idSite in the request.
[17-Aug-2014 08:05:05 UTC] Error in Piwik (tracker): Invalid idSite: ‘0’

[19-Aug-2014 09:39:50 UTC] Error in Piwik (tracker): Invalid idSite: ‘0’
[19-Aug-2014 10:49:27 UTC] PHP Fatal error: Class ‘Piwik_Plugin’ not found in /home/XXX/public_html/analytics/plugins/ExampleUI/ExampleUI.php on line 27
[19-Aug-2014 10:49:27 UTC] Error in Piwik: The class ExampleUI couldn’t be found in the file ‘/home/XXX/public_html/analytics/plugins/ExampleUI/ExampleUI.php’
[19-Aug-2014 10:49:44 UTC] PHP Fatal error: Class ‘Piwik_Plugin’ not found in /home/XXX/public_html/analytics/plugins/ExampleUI/ExampleUI.php on line 27

[20-Aug-2014 19:12:48 UTC] Error in Piwik (tracker): An unexpected website was found, check idSite in the request.
[20-Aug-2014 19:56:22 UTC] Error in Piwik (tracker): Invalid idSite: ‘0’

YES! It IS counting.
Th 21 Aug - 07:28:37
IP: 66.171.XXX.XXX
1 Actions
And much more…

Piwik Console is known to be not compatible with PHP-CGI (you are using cgi-fcgi). Please execute console using PHP-CLI. For instance "/usr/bin/php-cli console …"
Well, i have NO idea what to make out of it…

Edit 1: Forgot to delete some server infos…
Edit 2: Changes the Value for fbsql.max_connections from 128 to 256 … hopefully thats enough -.-


#11

I thought maybe the process of generating the reports by webcron.
So I have the shorten the period, the webcron runs now every 15 minutes.
But the error still exists.

To summarize, the counting itself is working. The visitor log shows new entries.
But generating the reports by webcron does not work anymore after upgrade to 2.5.
Generating the reports by accessing with the browser works.

I have no further ideas.
The browser option is not really a solution, because I often access the piwik statistics by app or wordpress plugin.


#12

Not completely, as i had mentioned it already. I have three Piwik Installs, for several projects and type of sites.
Two are running like normal, only one is ‘broken’

But also, no clue whatsoever :frowning:


#13

I just have opened my SQL to check if there is maybe a huge overhang that prevents working or whatever that I could see, but besides of 3GB or useless Data i found that it is really 100% still counting.


12891042 	25 	4e9f7cb0027888cb 	23:41:59 	1 	1 	1 	0 	1 	2014-08-23 00:14:29 	2014-08-23 00:14:29 	119 	118 	119 	118 	1 	0 	0 	0 	0 	0 	2 	Bing 	http://www.bing.com/search?q=XXXXXXXXXXX&src=IE-TopResu...	XXXXXXXXXXX 	de4fd05be5ef1779 	WI7 	7 	IE 	11.0 	0 			1920x1080 	0 	0 	1 	0 	0 	0 	0 	0 	0 	1 	5f5bcac7 	de-de 	de 	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	kabel-deutschland.de

If this line of death would just stop… if someone could find THAT error i would be really happy!
[attachment 1868 piwik.jpg]

Edit: I have made a Systemcheck, everything went fine, just this “location detection” tells me that it would be function, but i would use a not recommended whatever…" hard to translate to english ^^" … Rest went as expected. So even Piwik tells me that everything on systemside is fine… But still dead!


#14

I was running into the same issue with no new visits displaying and archiving saying it didn’t have any new visits after upgrading to 2.5.0. I also tried doing a rollback and re-running the upgrade but it still didn’t work.

Then it hit me; I had changed my piwik.php and piwik.js file names! I went and looked at the directory and sure enough there were new versions of those two files and they have significantly different code in them. Once I renamed the new files to my custom names, I started getting tracking information again. I have done many previous upgrades without updating the file names again and not run into problems, but I suppose the new code is different enough to cause the old versions not to work. Hope this helps!


#15

Sadly i have never changed any piwik files. No idea whatsoever to change there anyways.
But i will try to delete all the old files and reinstall with complete new downloaded version of piwik, maybe that helps, stupid why I haven’t tried that already -.-


#16

Ookay, this will be my last posting here and will be one time updated as fast as i know whats the correct solution.

As for me the solution is, that i had to edit my old cronjob. It seems that Piwik got there a major Update too that changed the Path/Command for the Cronjob Auto-Archiving process.

On the right way i got pushed by thomas-piwik in the Thread http://forum.piwik.org/read.php?2,118765,page=1#msg-119129
BUT, i created too many Crons to tell whitch one is the correct one. So don’t just do that like me, could ‘kill’ your server :wink:

But hopefully also others can get their ‘stuck’ Piwik run the right way again.

Thanks everybody!!!


#17

Same issue here, no tracking after update to 2.5.0.
The visitors log shows visitors, but no tracking information.

I’m using PiWik w/o any modifictions.


#18

@j2w: Did you follow the Guide for medium/high Traffic sites? If yes, you properbly had to set up a Cronjob.

Check your Cronjob if it looks like on http://piwik.org/docs/setup-auto-archiving/

Because i HAD an very old cronjob created in 2011 and after i used the new Cronjob, everything got fixed. Will only need a while to calculate everything, so be patient :slight_smile:


#19

Hi caylean, the cronjob exists and was not changed (and looks like as described in the documentation). I have to use a web cron.


#20

I have the same situation as j2w and I am using a web cron.

I think this issue is really related to the web cron script, which seems not working anymore with piwik 2.5.
My configuration is excatly set as in the piwik documentation.