"Unique visitors" column disappears


(Freott) #1

Hi,

Using the “table with more statistics” after choosing menu options events > events I am having trouble displaying unique visitors.

The column for unique visitors only seem to appear when I choose the time interval “one day” or “date range” with a maximum of 2 days. If I increase the range to more than 2 days the column just disappears, same goes for week/month/year.

Is this intended or is it a bug?

Thanks in advance


(Lukas Winkler) #2

Hi,

This is not a bug but a default to improve the performance.

You can enable unique visitor calculation for years and custom ranges as explained here:

https://matomo.org/faq/how-to/faq_113/

[General]
enable_processing_unique_visitors_day = 1
enable_processing_unique_visitors_week = 1
enable_processing_unique_visitors_month = 1
enable_processing_unique_visitors_year = 0
enable_processing_unique_visitors_range = 0

(Freott) #3

Hi, thanks for the quick response.

I’m afraid it did not help. I followed the steps; added a 1 to all of the values you mentioned in config.ini.php and then I ran invalidation of all historical data but still same results as earlier.

According to default values I should have been able to see unique visitors for week and month from the beginning, but as I mentioned in my post I am only able to see unique visitors for one day or 2 day range. Any idea what could be the cause?


(Freott) #4

I still haven’t managed to solve this issue. Do you have any advice for me?


(Freott) #5

Hi again,

This is a vital feature for my customer and if we can’t get it to work we may be forced to switch to a different analytics tool. Is this something that can’t be solved?