Unable to read INI file - Your host may have disabled parse_ini_file()

Dear Piwik team,

I’ve been using Piwik for years without any problem, but I cannot access my Piwik data since a few weeks.

Hereunder is the error message I obtain when trying to connect: http://les-yeux-du-monde.fr/piwik/

An error occurred

Unable to read INI file
{/home/lesyeuxdu/www/piwik/config/global.ini.php}: Syntax error in INI
configuration: Your host may have disabled parse_ini_file().

I looked for a solution but could not find any

I thank you very much for your help and support

1 Like

Hi Charles

please check the file /home/lesyeuxdu/www/piwik/config/global.ini.php is present.
if it is, check it has “read” permission (ie. chmod 644)

Dear Matthieu, thank you very much for your reply

I changed global.ini.php file permission from 604 to 644, but I’m still getting the same error

Should I modify permissions for other files according to you?

Thank you so much for your help

Hi Charles
can you check with your hosting provider that the function parse_ini_file is enabled on your server? or you can try create a php file <?php var_dump(function_exists('parse_ini_file')); ?> and write here the output

Hi Matthieu,

Here is the message I obtain through this php file: bool(true)

Any idea what this means?


Charles, I was checking that the function parse_ini_file is available on your server and it is. So the issue must be that PHP doesn ot have access to it… could you maybe try to chmod with 755 or so? not sure what is the problem…

Hi Matthieu,

Modifying the permission to 755 did not solve the problem unfortunately.

I could not find any similar problem through the web and I still don’t understand what happened and why it’s not working anymore… :frowning:

Maybe try to delete /home/lesyeuxdu/www/piwik/config/global.ini.php and re-upload a fresh version from here: https://raw.githubusercontent.com/piwik/piwik/master/config/global.ini.php

Hi Matthieu,

I deleted my file and replaced it by the one you mentionned (without any modification ; should I change anything before uploading it?) but I’m still getting the same problem as you can see here: http://les-yeux-du-monde.fr/piwik/

Thanks a lot for your investation on my case!


Check your files to make sure they have not been overwritten by a trojan or crack. The fix for me was to clean up the comprised files (re-install)… and it worked.


Just removed the first line of my config.ini.php file which was overwritten and I can now get connected!! Thanks a lot!

However, here is a new problem: I can’t have access to the data. Hereunder is the message I have in every frame:

                SQLSTATE[42000]: Syntax error or access violation: 

1142 CREATE command denied to user ‘admin’@‘’ for table

This does not appear in the data from the period before the first problem (e.g. if I want to access data in March everything is fine)
What could be the problem now?

Many thanks!

Your Mysql user must have the CREATE privilege, see: Piwik Requirements - Analytics Platform - Matomo

Hi Matthieu, many thanks for all your support

Sorry for my late answer, I’ve been trying to modify the privieges for ‘’ but I don’t even what it refers to.
I have been through my phpmyadmin dashboard but I was unable to find something helpful

I already have some table working, so I guess I should not CREATE any new table, just modify some permissions right?
Could you explain to me how I should proceed? I am a real newbie here.

Kind regards,