Unable to add new sites on fresh install


#1

This issue is regarding a fresh install of 2.7.0. It was installed using Softaculous.

When logged in as a superuser, in the Websites Management page…

[ul]
[li] It says You currently have access to 0 websites even though there is one site.
[/li][li] It continually says Loading data…, but nothing ever loads (see image attatched)
[/li][li] When I click one of the Add a new website buttons, they both disappear.
[/li][/ul]

I’ve tried completely deleting and reinstalling three times (once manually, twice using Softaculous), and I’ve also tried different browsers. Each time, the exact same issue.

Any suggestions? Thanks.


(Matthieu Aubry) #2

in your browser, in the Developer tools > Console do you see some error? or in the Network tab?


#3

I appreciate the reply. Yes, this is what shows in the console when I navigate to Websites Management:


TypeError: Cannot read property 'searchKeywordParametersGlobal' of null
    at http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:2196:1201
    at responseHandler (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:2174:1405)
    at B (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:319:5)
    at http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:320:173
    at h.$eval (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:328:456)
    at h.$digest (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:326:218)
    at h.$apply (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:329:264)
    at g (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:293:23)
    at I (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:297:109)
    at XMLHttpRequest.y.onreadystatechange (http://analytics.example.com/index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:298:154) index.php?module=Proxy&action=getCoreJs&cb=a07a60c3891d1b943197765fd924bead:310


#4

I removed Piwik completely, and manually installed version 2.4.0. It worked perfectly.

Then, I ran the automated update to 2.7.0. Same problem all over again.


(Matthieu Aubry) #5

Hi Tman,

sorry cannot reproduce the issue. maybe you could PM me access to your piwik + link to this blog post?