Unable to access Matomo Report due to permission issue

Hello,
I am an admin and now I cannot read the Matomo reports anymore.
When trying to click on REPORTING, the message reads:

Forbidden
You don’t have permission to access this resource.

Thanks for letting me know what to do from here!
RP

This menu doesn’t exist.
Can you provide a screenshot?

Yes, see the attached snapshot please.

along with the system report:

Please check your webserver config (or .htaccess files) to see if there are any rules that deny direct access to URLs ending with .php

Thanks,
I just don’t know how to check that webserver config,
Should I call the webhost for that?
Meanwhile, I know that I was able to access the Matomo report until last week… so I don’t know why the access has been denied after that…

Hello, I contacted the webhost, which is GODADDY, and here is their answer:

We no longer allow .php access. And it cannot be allowed.
The reason is because security

Possible solutions:

link into native wordpress api\wp-json. This is an access web request.

Otherwise redesign the functionality in question. go to another product c panel or vps dedicated server.

…so what to do from here?
Thanks
RP

Hi RP,

Do your summary reports work?
Can you try to set the option Endpoint for HTTP Tracking API available from the menu Matomo Analytics > Settings to the Wordpress API?
Can you share with us your system report available from Matomo Analytics > Diagnostics?

Kind regards

Mat

Hello, thanks for your reply,
I did not understand what you mentioned:

”set the option Endpoint for HTTP Tracking API available from the menu Matomo Analytics > Settings to the Wordpress API ”

Set the option to what?
From what I see on Settings › Tracking , it reads :
”Endpoint for HTTP Tracking API ” then next to it , it is set to ”DEFAULT”
Should I set it to : ”Through Wordpress Set API” ?

Please see attached file below.

I did try that, but the message is the same as mentioned previously:
FORBIDDEN

Thanks for any further help…
RP

			  # Matomo
  • Matomo Plugin Version: 4.5.0
  • Config exists and is writable.: Yes ("$abs_path/wp-content/uploads/matomo/config/config.ini.php" )
  • JS Tracker exists and is writable.: Yes ("$abs_path/wp-content/uploads/matomo/matomo.js" )
  • Plugin directories: Yes ([{“pluginsPathAbsolute”:"$abs_path/wp-content/plugins/matomo/plugins",“webrootDirRelativeToMatomo”:"…/"}])
  • Tmp directory writable: Yes ($abs_path/wp-content/cache/matomo)
  • Matomo Version: 4.5.0
  • Matomo Blog idSite: 1
  • Matomo Install Version: 4.2.0 (Install date: 2021-03-20 10:01:18)
  • Upgrades outstanding: No
  • Upgrade in progress: No

Endpoints

  • Matomo JavaScript Tracker URL: ($site_url/wp-content/uploads/matomo/matomo.js)
  • Matomo JavaScript Tracker - WP Rest API: ($site_url/wp-json/matomo/v1/hit/)
  • Matomo HTTP Tracking API: ($site_url/wp-content/plugins/matomo/app/matomo.php)
  • Matomo HTTP Tracking API - WP Rest API: ($site_url/wp-json/matomo/v1/hit/)

Crons

  • Server time: 2021-12-25 19:28:26
  • Blog time: 2021-12-25 11:28:26 (Below dates are shown in blog timezone)
  • Sync users & sites: Next run: 2021-12-26 04:44:18 (17 hours 15 min) ( Last started: 2021-12-25 04:48:18 (-6 hours 40 min). Last ended: 2021-12-25 04:48:19 (-6 hours 40 min). Interval: daily)
  • Archive: Next run: 2021-12-25 11:44:18 (15 min 52s) ( Last started: 2021-12-25 11:12:10 (-16 min 16s). Last ended: 2021-12-25 11:12:26 (-16 min 0s). Interval: hourly)
  • Update GeoIP DB: Next run: 2022-01-11 04:44:18 (16 days 17 hours) ( Last started: 2021-12-12 05:01:10 (-13 days 6 hours). Last ended: 2021-12-12 05:01:15 (-13 days 6 hours). Interval: matomo_monthly)

Mandatory checks

  • PHP version >= : ok
  • PDO extension: ok
  • PDO\MYSQL extension: ok
  • MYSQLI extension: ok
  • Other required extensions: ok
  • Required functions: ok
  • Required PHP configuration (php.ini): ok
  • Directories with write access: ok
  • Directories with write access for Tag Manager: ok

Optional checks

  • Recommended Private Directories: ok
  • Tracker status: ok
  • Memory limit: ok
  • Time zone: ok
  • Open URL: ok
  • PageSpeed disabled: ok
  • GD > 2.x + Freetype (graphics): ok
  • Other extensions: ok
  • Other functions: ok
  • Filesystem: ok
  • Last Successful Archiving Completion: ok
  • Database abilities: ok
  • Warning Max Packet Size: warning (It is recommended to configure a ‘max_allowed_packet’ size in your MySQL database of at least 64MB. Configured is currently 16MB. )
  • Geolocation: ok
  • Update over HTTPS: ok
  • Supports Async Archiving: No
  • Location provider ID: geoip2php
  • Location provider available: Yes
  • Location provider working: Yes
  • Warning Proxy header: HTTP_X_REAL_IP (A proxy header is set which means you maybe need to configure a proxy header in the Advanced settings to make location reporting work. If the location in your reports is detected correctly, you can ignore this warning. Learn more: https://matomo.org/faq/wordpress/how-do-i-fix-the-proxy-header-warning-in-the-matomo-for-wordpress-system-report/)
  • Warning Proxy header: HTTP_X_FORWARDED_FOR (A proxy header is set which means you maybe need to configure a proxy header in the Advanced settings to make location reporting work. If the location in your reports is detected correctly, you can ignore this warning. Learn more: https://matomo.org/faq/wordpress/how-do-i-fix-the-proxy-header-warning-in-the-matomo-for-wordpress-system-report/)
  • Matomo URL: Yes ($site_url/wp-content/plugins/matomo/app)

Matomo Settings

  • Track mode: default
  • Track codeposition: footer
  • Track api endpoint: restapi
  • Track js endpoint: default
  • Version history: 4.5.0, 4.4.2, 4.3.0, 4.2.0
  • Core version: 4.5.0
  • Last tracking settings update: 1640457268
  • Last settings update: 1640457268
  • Delete all data uninstall: No
  • Track ecommerce: No

Logs

  • Warning archive_main: 2021-12-23 21:50:34 (Renderer format ‘console’ not valid. Try any of the following instead: . => ApiRenderer.php:143; ResponseBuilder.php:43; Request.php:281; Request.php:559; Tasks.php:130; Tasks.php:94; TaskLoader.php:32; Scheduler.php:94; API.php:69; CronArchive.php:626; CronArchive.php:264; Access.php:670; CronArchive.php:269; ScheduledTasks.php:332; class-wp-hook.php:301; class-wp-hook.php:327; plugin.php:518; wp-cron.php:138; cron.php:880; cron.php:996; class-wp-hook.php:303; class-wp-hook.php:327; plugin.php:470; wp-settings.php:600; wp-config.php:96; wp-load.php:50; wp-blog-header.php:13; index.php:17;)

WordPress

  • Home URL: $site_url
  • Site URL: $site_url
  • WordPress Version: 5.8.2
  • Number of blogs: 1
  • Multisite Enabled: No
  • Network Enabled: No
  • WP_DEBUG: No
  • WP_DEBUG_DISPLAY: Yes
  • WP_DEBUG_LOG: No
  • DISABLE_WP_CRON: -
  • FORCE_SSL_ADMIN: Yes
  • WP_CACHE: No
  • CONCATENATE_SCRIPTS: -
  • COMPRESS_SCRIPTS: -
  • COMPRESS_CSS: -
  • ENFORCE_GZIP: -
  • WP_LOCAL_DEV: -
  • WP_CONTENT_URL: $site_url/wp-content
  • WP_CONTENT_DIR: $abs_path/wp-content
  • UPLOADS: -
  • BLOGUPLOADDIR: -
  • DIEONDBERROR: -
  • WPLANG: -
  • ALTERNATE_WP_CRON: Yes
  • WP_CRON_LOCK_TIMEOUT: 60
  • WP_DISABLE_FATAL_ERROR_HANDLER: -
  • MATOMO_SUPPORT_ASYNC_ARCHIVING: -
  • MATOMO_TRIGGER_BROWSER_ARCHIVING: -
  • MATOMO_ENABLE_TAG_MANAGER: -
  • MATOMO_SUPPRESS_DB_ERRORS: -
  • MATOMO_ENABLE_AUTO_UPGRADE: -
  • MATOMO_DEBUG: -
  • MATOMO_SAFE_MODE: -
  • MATOMO_GLOBAL_UPLOAD_DIR: -
  • MATOMO_LOGIN_REDIRECT: -
  • Permalink Structure: /%postname%/
  • Possibly uses symlink: No
  • Upload base url: $site_url/wp-content/uploads
  • Upload base dir: $abs_path/wp-content/uploads
  • Upload url: $site_url/wp-content/uploads/2021/12
  • Custom upload_path: wp-content/uploads
  • Custom upload_url_path:
  • Compatible content directory: Yes

WordPress Plugins

MU Plugins

  • System Plugin: 4.19.0

Plugins

  • Advanced Editor Tools (previously TinyMCE Advanced): 5.6.0
  • Akismet Anti-Spam: 4.2.1
  • AWSM Team Pro: 1.1.4
  • BackWPup: 3.10.0 (Network enabled)
  • Business Directory Google Maps: 5.2.1
  • Business Directory PayPal: 5.0.5
  • Business Directory Plugin: 5.15.4
  • Business Directory Plugin - Discount Codes Module: 5.0.1
  • Business Directory Plugin - Enhanced Categories Module: 5.0.12
  • Business Directory Plugin - File Attachments Module: 5.1.2
  • Business Directory Plugin - Migrator: 5.0.4
  • Business Directory Plugin - ZIP Search Module: 5.2
  • Business Directory Ratings: 5.2
  • Business Directory Regions: 5.3.2
  • Classic Editor: 1.6.2
  • Colibri Add Basic Form Styles: 1.0
  • Colibri Page Builder: 1.0.208
  • Colibri Page Builder PRO: 1.0.227-pro
  • Contact Form 7: 5.5.3
  • Elfsight Testimonials Slider CC: 1.3.0
  • Gutenberg: 12.2.0
  • Matomo Analytics - Ethical Stats. Powerful Insights.: 4.5.0
  • MC4WP: Mailchimp for WordPress: 4.8.6
  • Ninja Forms: 3.6.7
  • UpdraftPlus - Backup/Restore: 1.16.66
  • WooCommerce: 5.9.0
  • WPBakery Page Builder: 6.7.0
  • WP EventsPlus: 2.5.7
  • Yoast SEO: 17.7.1
  • Active Plugins: 29 (akismet awsm-team-pro backwpup business-directory-attachments business-directory-categories business-directory-discount-codes business-directory-googlemaps business-directory-migrate business-directory-paypal business-directory-plugin business-directory-ratings business-directory-regions business-directory-zipcodesearch classic-editor colibri-add-basic-form-styles colibri-page-builder-pro colibri-page-builder contact-form-7 elfsight-testimonials-slider-cc gutenberg js_composer mailchimp-for-wp matomo ninja-forms tinymce-advanced updraftplus woocommerce wordpress-seo wpeventplus)
  • Theme: colibri-wp (colibri-wp)

Server

  • Server Info: Apache
  • PHP OS: Linux
  • PHP Version: 7.3.30
  • PHP SAPI: cgi-fcgi
  • PHP Binary Name: php-cgi
  • PHP Error Reporting: 0 After bootstrap: 0
  • Timezone: UTC
  • WP timezone: America/Los_Angeles
  • Locale: en_US
  • User Locale: en_US
  • Memory Limit: 256M (At least 128MB recommended. Depending on your traffic 256MB or more may be needed.)
  • WP Memory Limit: 40M
  • WP Max Memory Limit: 256M
  • Timezone version: 2020.4
  • Time: 1640460506
  • Max Execution Time: 300
  • Max Post Size: 100M
  • Max Upload Size: 104857600
  • Max Input Vars: 1000
  • Disabled PHP functions: No
  • zlib.output_compression is off: Yes
  • Curl Version: 7.79.1, OpenSSL/1.1.1l
  • Suhosin installed: No

Database

  • MySQL Version: 5.7.26
  • Mysqli Connect: Yes
  • Force MySQL over Mysqli: No
  • DB Prefix: wp_y8d7zvrp1j_
  • DB CHARSET: utf8
  • DB COLLATE:
  • SHOW ERRORS: No
  • SUPPRESS ERRORS: No
  • Uses Socket: No
  • Uses IPv6: No
  • Matomo tables found: 87
  • DB tables exist: Yes
  • Matomo users found: 2
  • Matomo sites found: 1
  • Required permissions: OK

Browser

  • Browser: (Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36)
  • Language: fr-fr,fr,en-us,en

Hi @rhpdc

Yes please. And tell us if it solves your issue.

Kind regards

Mat

Hello, thanks for your reply,
I did as asked, and I am still unable to access any kind of report or what so ever!
As before, the report page states:


Forbidden
You don’t have permission to access this resource. ”

Please let us know what to do from there…
R

Hi @rhpdc

Unfortunately we have no workaround to fix this issue.
The only solution I see for now is to migrate your hosting plan to a dedicated web server.
Kind regards,

Mat

one last thing @rhpdc : can you see the visits in the summary page?