Ugrade failed


(kuse) #1

Hi!

I just upgrade my 0.2.2 Piwik Version to Version 0.4.1 manually.
Everything worked fine, but after upgrading the database automatically, i get stucked on the login-page.

If i type in a wrong username/password, i get an error-message, what seems to be ok.

If i type in the correct username and password, piwik keep staying on the login-screen (and don’t get any error-messages)…

What’s wrong? Has anyone an idea of what i can do?

Thanks
Kuse


(vipsoft) #2

Remove your config.ini.php and let piwik regenerate it on the upgrade screen. Select the option to use your existing tables.


(kuse) #3

Hi!
Thank you for your quick answer!
I did what you told me, but piwik still acts like before… i’m able to login, but piwik keeps staying on the login screen.

I have PHP Version 5.2.3, and MYSQL 5.0.45, and i tried in different browsers.

Any ideas what i should do in this situation?

Greetings
kuse


(vipsoft) #4

If you’re using any cookie blockers, make sure you allow your site.

If you’ve bookmarked your login page, change the URL so that instead of:

http://yourhost/piwik/index.php?module=Login

it simply reads:

http://yourhost/piwik/

(kuse) #5

Hi!
Thanks for your answers!

I don’t use any cookieblockers, and i didn’t bookmark the page.
I tried to login on different browsers and on different systems (osx/windows), and still the same thing happens. I’ll try it at home with a different internet access.

Greetings
kuse


(vipsoft) #6

Is your Piwik server behind a reverse proxy?


(kuse) #7

Mmmhhh… I have to ask the IT-Specialist of our Office. I’ll ask him as soon as he comes back from holidays in a few days.

Thanks and greetings
kuse


(vipsoft) #8

The other thing to try is install Piwik in a fresh/new folder. You may have a mix of old and new files.


(kuse) #9

Hi!
I installed piwik in a new directory, and now it works!

Thank you very much for your time and help.

Greetings
kuse