TypeError: X.shift is not a function


#1

I just completing my Piwik installation and everything works well except that I got an error (visible on Firebug - screenshot attached) that says:


TypeError: X.shift is not a function
...arguments.length;W+=1){X=arguments[W];Y=X.shift();if(n(Y)){L[Y].apply(L,X)}else{...

Tried to google it and search in the forum and bug tracker but I could not find anyone reported the same issues.

It is Piwik 2.12.1 running on Windows 8 R2 with IIS7. If anyone could give any input on what I should do to solve this. Thank you.


(Matthieu Aubry) #2

in Administration > System check, does it show any warning?

you can also try to delete the tmp/ folder in Piwik and try again?


#3

Thank you for your response Matt.

I have deleted tmp/ and it didn’t help.

System check shows all green except for two warnings:
[ol]
[li] Curl : Note: Piwik’s One Click update requires write-permissions to the Piwik folder and its contents.
[/li][li] Geolocation: Geolocation works, but you are not using one of the recommended providers. If you have to import log files or do something else that requires setting IP addresses, use the PECL GeoIP implementation (recommended) or the PHP GeoIP implementation.
[/li][/ol]

I didn’t bother to address those two warnings because:
[ol]
[li] The server doesn’t have access to the Internet so auto update won’t work anyway.
[/li][li] We don’t require geolocation stats.
[/li][/ol]

Anything else I should check? Thank you.


(Matthieu Aubry) #4

Yes can you try upgrade to latest 2.13.0-RC? 301 Moved Permanently


#5

I can try that. But suppose this solves the issue, is it stable enough for production environment?

Cheers,


#6

Hi Matt,

I thought I would update on this topic. I did reinstall with the latest stable version (2.12.1) and it seems to resolve the issue. I was reluctant to use beta version so I tried reinstall the same version and fortunately it somehow resolved it. Thanks for your help.

I do have other issues now but I will post in different thread because it is different topic.