Turn off cron?


#1

About every hour I get an email from Piwik (see below).
I have no idea what is going on, but I would like to stop it.
How do I stop this cron job - or at least the emails? It occurs on its own… I don’t recall creating it.
Any help, greatly appreciated.

Email received every hour
Subject: Cron php /home/xxxxx/public_html/stats/misc/cron/archive.php – url=http://xxxxx/stats/
Message:

Using this ‘archive.php’ script is no longer recommended.
Please use ‘/path/to/php /home/xxxxx/public_html/stats/console core:archive – url=http://xxxxx/stats/’ instead.
To get help use '/path/to/php /home/xxxxx/public_html/stats/console core:archive --help’
See also: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

INFO [2014-07-02 05:56:01] [34e00] ---------------------------
INFO [2014-07-02 05:56:01] [34e00] INIT
INFO [2014-07-02 05:56:01] [34e00] Piwik is installed at: http://xxxxx/stats/index.php
INFO [2014-07-02 05:56:01] [34e00] Running Piwik 2.3.0 as Super User
INFO [2014-07-02 05:56:01] [34e00] ---------------------------
INFO [2014-07-02 05:56:01] [34e00] NOTES
INFO [2014-07-02 05:56:01] [34e00] - If you execute this script at least once per hour (or more often) in a crontab, you may disable ‘Browser trigger archiving’ in Piwik UI > Settings > General Settings.
INFO [2014-07-02 05:56:01] [34e00] See the doc at: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo
INFO [2014-07-02 05:56:01] [34e00] - Reports for today will be processed at most every 10 seconds. You can change this value in Piwik UI > Settings > General Settings.
INFO [2014-07-02 05:56:01] [34e00] - Reports for the current week/month/year will be refreshed at most every 3600 seconds.
INFO [2014-07-02 05:56:01] [34e00] - Archiving was last executed without error 14 days 13 hours ago
INFO [2014-07-02 05:56:01] [34e00] - Will process 2 websites with new visits since 14 days 13 hours , IDs: 1, 2
INFO [2014-07-02 05:56:01] [34e00] ---------------------------
INFO [2014-07-02 05:56:01] [34e00] START
INFO [2014-07-02 05:56:01] [34e00] Starting Piwik reports archiving…
INFO [2014-07-02 05:56:04] [34e00] Archived website id = 1, period = day, 420 visits in last 2 days, 166 visits today, Time elapsed: 2.286s
INFO [2014-07-02 05:56:07] [34e00] Archived website id = 1, period = week, 6534 visits in last 16 weeks, 573 visits this week, Time elapsed: 3.494s
ERROR [2014-07-02 05:56:12] [34e00] Got invalid response from API request: http://xxxxx/stats/index.php?module=API&method=API.get&idSite=1&period=month&date=last16&format=php&token_auth=xxxxx&trigger=archivephp. Response was ’
Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 71 bytes) in /home/xxxxx/public_html/stats/core/DataTable.php on line 1155


(Matthieu Aubry) #2

the error is: Allowed memory size of 67108864 bytes exhausted (tried to allocate 71 bytes) in /home/xxxxx/public_html/stats/core/DataTable.php

See the solution here: Piwik reports this error and fails: "Fatal error: Allowed memory size of X bytes exhausted (tried to allocate X bytes)". What should I do? - Analytics Platform - Matomo