Translator.php(89): Warning - vsprintf(): Too few arguments - Matomo 3.11.0

I am trying to Archive Reports automatically.
System --> General Settings --> Archiving Settings

I have setup a cron job (that runs daily). The executable script is a .php file with the following contents:
/usr/local/bin/php -f /public_html/matomo/console core:archive > /matomo-archives/output.log

I’m borrowing the syntax, listed here:

However Matomo is giving me the following error message:
WARNING: /storage/ssd1/722/12377720/public_html/matomo/core/Translation/Translator.php(89): Warning - vsprintf(): Too few arguments - Matomo 3.11.0 - Please report this message in the Matomo forums: (please do a search first as it might have been reported already)


This error has been reported quite a few times recently, so there might be some incorrect string.

The error indicates that somewhere there is a translation string that has more placeholders than variables that will get formatted into it. Unfortunatly the warning doesn’t say where, so it is quite hard to find or reproduce.

Could you please mention your Language and maybe what should have been printed in place of the warning?

Every page on my site has the lang tag set to:
<html lang="en">
(Not sure if that answers your question, Lucas.)

I’m attaching a screen snapshot that shows where the error is appearing.

The “result” is supposed to be an “output.log” file that is generated (daily). But (thus far) no log files have been generated.

I tweaked my .PHP file. I modified my “Matomo base URL”.

/usr/local/bin/php -f /public_html/matomo/console core:archive > /matomo-archives/output.log

I am no longer getting the Warning message, on the “General Settings” page. However when I check the “matomo-archives” directory, I do not see the output.log file. Any ideas?


Great that you found a solution.

Are you sure there is no . in from of /matomo-archives/output.log otherwise it would look at the path starting from the root (/) directory.

You can also remove > /matomo-archives/output.log to not redirect the output into a file.

Where does the archived data go, if I choose NOT to specify an output file?

Hi @mengelsen,

The source of the issue has been found: