Tracking SSL pages failing


#1

I have a site that uses SSL for all pages. The site is implemented in WordPress and I’m using the WP-Piwik plugin. The problem is that the only pages that show up in Piwik are the non-SSL homepage (need to tweak my .htaccess to redirect that to the SSL homepage) and the 404 page. Does anyone have ideas on what might be causing this? Any help is appreciated!

Thanks!


(Matthieu Aubry) #2

Go on your site on HTTPS and check your Developer Console in browser. What’s the error when connecting to piwik server?


#3

I don’t get any errors. I do notice that the “main URL” value is “http://flojos.com” and not “https://flojos.com”. Is that the problem? I don’t see a way to change that setting in WP-Piwik (happy to go into mySQL and tweak it if needed).

The test script outputs the following (my Piwik install URL replaced with “***”):

`WP-Piwik 1.0.3
Mode: http

Test 1/3: global.getPiwikVersion

string(6) “2.14.3”

array(2) {
[0]=>
string(156) "HTTP/1.1 200 OK
Date: Fri, 02 Oct 2015 12:39:08 GMT
Server: Apache
Vary: *
Transfer-Encoding: chunked
Content-Type: application/json; charset=utf-8

"
[1]=>
string(146) “http://***/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3D15&token_auth=…”
}

Test 2/3: SitesManager.getSitesWithAtLeastViewAccess

array(1) {
[0]=>
array(16) {
[“idsite”]=>
int(15)
[“name”]=>
string(6) “Flojos”
[“main_url”]=>
string(17) “http://flojos.com
[“ts_created”]=>
string(19) “2014-06-20 18:55:11”
[“ecommerce”]=>
int(0)
[“sitesearch”]=>
int(1)
[“sitesearch_keyword_parameters”]=>
string(0) “”
[“sitesearch_category_parameters”]=>
string(0) “”
[“timezone”]=>
string(19) “America/Los_Angeles”
[“currency”]=>
string(3) “USD”
[“excluded_ips”]=>
string(0) “”
[“excluded_parameters”]=>
string(0) “”
[“excluded_user_agents”]=>
string(0) “”
[“group”]=>
string(0) “”
[“type”]=>
string(7) “website”
[“keep_url_fragment”]=>
int(0)
}
}

array(2) {
[0]=>
string(156) "HTTP/1.1 200 OK
Date: Fri, 02 Oct 2015 12:39:10 GMT
Server: Apache
Vary: *
Transfer-Encoding: chunked
Content-Type: application/json; charset=utf-8

"
[1]=>
string(169) “http://***/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3D15&token_auth=…”
}

Test 3/3: SitesManager.getSitesIdFromSiteUrl

array(1) {
[0]=>
array(1) {
[“idsite”]=>
int(15)
}
}

array(2) {
[0]=>
string(156) "HTTP/1.1 200 OK
Date: Fri, 02 Oct 2015 12:39:11 GMT
Server: Apache
Vary: *
Transfer-Encoding: chunked
Content-Type: application/json; charset=utf-8

"
[1]=>
string(194) “http://***/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3D15%26url%3Dhttps%3A%2F%2Fflojos.com&token_auth=…”
}

array(2) {
[“global_settings”]=>
array(56) {
[“revision”]=>
string(10) “2015072101”
[“last_settings_update”]=>
string(10) “1442932491”
[“piwik_mode”]=>
string(4) “http”
[“piwik_url”]=>
string(31) “http://***/”
[“piwik_path”]=>
string(0) “”
[“piwik_user”]=>
string(0) “”
[“piwik_token”]=>
string(3) “set”
[“auto_site_config”]=>
string(1) “1”
[“default_date”]=>
string(9) “yesterday”
[“stats_seo”]=>
string(1) “0”
[“dashboard_widget”]=>
string(9) “yesterday”
[“dashboard_chart”]=>
string(1) “0”
[“dashboard_seo”]=>
string(1) “0”
[“toolbar”]=>
string(1) “0”
[“capability_read_stats”]=>
array(8) {
[“administrator”]=>
string(1) “1”
[“editor”]=>
string(1) “0”
[“author”]=>
string(1) “0”
[“contributor”]=>
string(1) “0”
[“subscriber”]=>
string(1) “0”
[“customer”]=>
string(1) “0”
[“shop_manager”]=>
string(1) “0”
[“wpsl_store_locator_manager”]=>
string(1) “0”
}
[“perpost_stats”]=>
string(1) “0”
[“plugin_display_name”]=>
string(8) “WP-Piwik”
[“piwik_shortcut”]=>
string(1) “0”
[“shortcodes”]=>
string(1) “0”
[“track_mode”]=>
string(2) “js”
[“track_codeposition”]=>
string(6) “header”
[“track_noscript”]=>
string(1) “0”
[“track_nojavascript”]=>
string(1) “0”
[“proxy_url”]=>
string(26) “//***/”
[“track_content”]=>
string(8) “disabled”
[“track_search”]=>
string(1) “0”
[“track_404”]=>
string(1) “0”
[“add_post_annotations”]=>
string(1) “0”
[“add_customvars_box”]=>
string(1) “0”
[“add_download_extensions”]=>
string(0) “”
[“disable_cookies”]=>
string(1) “0”
[“limit_cookies”]=>
string(1) “0”
[“limit_cookies_visitor”]=>
string(8) “34186669”
[“limit_cookies_session”]=>
string(4) “1800”
[“limit_cookies_referral”]=>
string(8) “15778463”
[“track_admin”]=>
string(1) “0”
[“capability_stealth”]=>
array(0) {
}
[“track_across”]=>
string(1) “0”
[“track_across_alias”]=>
string(1) “0”
[“track_feed”]=>
string(1) “0”
[“track_feed_addcampaign”]=>
string(1) “0”
[“track_feed_campaign”]=>
string(4) “feed”
[“track_heartbeat”]=>
string(1) “0”
[“cache”]=>
string(1) “1”
[“http_connection”]=>
string(4) “curl”
[“http_method”]=>
string(4) “post”
[“disable_timelimit”]=>
string(1) “0”
[“connection_timeout”]=>
string(1) “5”
[“disable_ssl_verify”]=>
string(1) “0”
[“piwik_useragent”]=>
string(3) “php”
[“piwik_useragent_string”]=>
string(8) “WP-Piwik”
[“track_datacfasync”]=>
string(1) “0”
[“track_cdnurl”]=>
string(0) “”
[“track_cdnurlssl”]=>
string(0) “”
[“force_protocol”]=>
string(8) “disabled”
[“update_notice”]=>
string(7) “enabled”
}
[“settings”]=>
array(6) {
[“name”]=>
string(0) “”
[“site_id”]=>
string(2) “15”
[“noscript_code”]=>
string(115) “


[“tracking_code”]=>
string(527) "

"
[“last_tracking_code_update”]=>
string(10) “1442932491”
[“dashboard_revision”]=>
string(1) “0”
}
}
`