Tracking not working in Firefox

I am facing the same problem…I am using 53.0.2. I removed all history, cookies and cache… Didn’t work for me.

1 Like

Does the problem only appear in firefox? Are you getting errors in the javascript console? Can you check in the network tab of your browsers developer tools if the piwik.js and piwik.php?[something] requests are not returning an error?

It is only in Firefox. Chrome and Safari are working well.

I do not see any error in console.

GET [HTTP/1.1 304 Not Modified 32ms]

GET [HTTP/1.1 200 OK 75ms]

The only thing I can think of at the moment is to temporarily enable the verbose tracker and see if anything odd is shown there: Tracking HTTP API: API Reference - Piwik Analytics - Developer Docs - v3

Did you turn the do not track me option off in firefox, otherwise piwik won’t be able to track anything. If this is the case, remove cookies and cache once more after you turned it off

No. I have not done any changes in firefox settings. It is downloaded and installed and thats it. No personal settings done.

Allright then go to options, uncheck protection against following… and then remove cookies and cache!

I am using Firefox (53.0.3 - 64bit) on Mac oS Sierra 10.12. There is no “Options”, but Preferences. I do not see any “Protection” section but I unchecked every setting under “Security”. Deleted full History, every kind of History, no benefit. Still the same. I will uninstall this Firefox, install it again and then try once more… Will update.

It is not in the protection section of firefox, it is in the section called privacy. There is just one checkbox there, uncheck it and then remove cookies and cache.

Found the problem: Firefox have a default setting “Do not Track”. I had to go to Preferences > Privacy > Click on “Manage your Do Not Track Settings” link and in the opened dialog box, I had to uncheck “Always Apply Do Not Track”.
Then only it worked.

For anyone in future having trouble finding the setting, there is a manual for it:

Hi. Started yesterday with a fresh Piwik installation for our upcoming plattform. As a Firefox user I faced the same problem, but…

  1. The ‘solution’ don´t seem to work at my side. The option is deactivated and the cache is clean - still no tracking for Firefox. Ad Blocker is down for the site - saw this in old threads. Chrome and Edge are tracked well.

  2. If I get all the messages right - the ‘Do not Track’ option is a standard setting in a fresh new version Firefox installation and this means no Piwik tracking for Firefox in the future at all? :fearful:

Hi @shenom,
Can you also check for errors/requests?

I am pretty sure firefox doesn’t enable DNT by default. (article from 2011) If it was, it would be pretty useless as it would show nothing about the users intention. (remember, DNT is just a friendly “hey, I wouldn’t like to be tracked” without consequences)

Microsoft has tried this with IE 10 and it wasn’t received well (and it resulted in piwik ignoring DNT in IE)

Hi Findus. Thx for the fast answer!

  1. It seems to be my Firefox installation. But not quit sure why. Checked my Firefox on mobile (same wlan network yesterday) and as I deactived the DNT there - Piwik tracked the site well.

On my Notebook nothing changes. Deactivated DNT, cleaned the cache and started in safe mode without AddOns - no tracking at all. The only line the Firefox console is spit out is this : JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:542

Seems a ‘special problem’ at my side. Don´t waste more energy on it. :wink:

  1. What makes me still think about it is what ‘mjaved495’ wrote in this post. Sounds like a fresh installation of Firefox - but had to deactivate DNT after installation. I´ll test this at my girls notebook soon.

I have the same problem. On a brand new installation of Firefox 56.0.1 DNT was active and I got the corresponding message from piwik 3.2.0 (Das Tracking ist bei Ihnen derzeit nicht aktiv, denn Ihr Browser hat uns mitgeteilt, dass Sie kein Tracking wünschen. … ) in one of my newer Typo3 projects. But also when I terminated tracking protection (Schutz vor Aktivitätenverfolgung deaktiviert) and cleared all caches and cookies and the whole chronic I still got the same message! On Opera, Edge, Android I don’t have this problem in this project. There the user can optOut if he wants. And also on an older Typo3 project (piwik 3.2.0 as well) this problem does not appear in the same firefox instance! In this oIder project I can switch off the optOut by activating DNT and switch it on again by deactivating DNT. What can be the reason for this difference in one and the same piwik version??Thanks for any idea!

For me (Firefox 56.0) the settings are a bit confusing:

If I am understanding correctly, “Schutz vor Aktivitätenverfolgung” is just a kind of adblocker that only blocks tracking script and is only active when you are in private mode. This setting has nothing to do with do-not-track, which you can disable in the next setting.

Interestingly this seems to imply that DNT is always on in the private mode by default.

Thank You for your quick answer. Yes, I also find that the settings are confusing.
If You choose “immer”, this means: “Do not track”.
If you choose “Nur wenn der Schutz…” this means: Do not track, if “Schutz vor Akt…” ist enabled. So, the only possibility to activate Tracking is - as far as I understand - to choose:
“Schutz vor Aktiv… " No and
"Nur wenn der Schutz…” yes
But as I already told You this doesn’t have any effect in my newer project. It doesn’t activate the tracking/optOut possibility.