Track time more exactly


(habakuk) #1

Hello,

I use piwik to track the usage of desktop applications - I use the bulk tracking to send the data to the piwik server.

In the applications several events are tracked in the same second and in piwks live view the order of the events shown is not the same order as they really happened.

I use the parameters ‘h’ (The current hour), ‘m’ (The current minute) and ‘s’ (The current second). But there is also the parameter ‘cdt’ (Override for the datetime of the request) - which I currently don’t use.

[ul]
[li] What is the difference between the two?
[/li][li] I probably should use ‘cdt’, but why is there ‘h’, ‘m’ and ‘s’ too?
[/li][li] Is it possible to add the fraction of a second to ‘s’ or to add Milliseconds to ‘cdt’?
[/li][/ul]

Thanks for your help!

Ciao!
Stefan


(habakuk) #2

Ok, I now use the parameter ‘cdt’ and invalidate the results with


http://piwik.piwik/?module=API&method=CoreAdminHome.invalidateArchivedReports&idSites=1&dates=2012-10-22&token_auth=XYZ

But I didn’t find a way to add milliseconds to the date.

Ciao!
Stefan


(Matthieu Aubry) #3

Hi Stefan,

when you import pageviews in a bulk request, they should be imported in the order that they are sent in the bulk request payload.

Are you seeing that Piwik does nt import the requests in the same order, from the same bulk request?


(habakuk) #4

Hi Matt,

wie checked it again - we send several events and urls in one second (in the right order) but for example the “Visitor Log” shows them in a random order.

Best regards!
Stefan


(habakuk) #5

I added an issue: https://github.com/piwik/piwik/issues/5808