System Check Filesystem NFS Fail?


#1

System Check
/!\ There are some issues with your system. Piwik will run, but you might experience some minor problems. See below for more information.

[quote]
Your server is using an NFS filesystem.
This means Piwik will be extremely slow when using file based sessions.

[quote]

I’ve just installed this on a new server running CentOS, my previous server which did not throw this error was Ubuntu however the filesystems where the same.

Previous server:


# df -T
Filesystem     Type     1K-blocks     Used Available Use% Mounted on
/dev/md3       ext4     957175772 91311940 817242044  11% /
udev           devtmpfs  11826784       12  11826772   1% /dev
tmpfs          tmpfs      4739428      424   4739004   1% /run
none           tmpfs         5120        4      5116   1% /run/lock
none           tmpfs     11848560        0  11848560   0% /run/shm
/dev/md0       ext4        186491    78762     98101  45% /boot
/dev/md2       ext4       1967504    41484   1826072   3% /tmp

Current server (with NFS Filesystem Error):


# df -T
Filesystem                    Type   1K-blocks     Used  Available Use% Mounted on
/dev/mapper/vg_beast-LogVol00 ext4  1152844716 19461548 1074822044   2% /
/dev/cciss/c0d0p1             ext4      495844    67291     402953  15% /boot
/usr/tmpDSK                   ext3     4128448   140232    3778504   4% /tmp
tmpfs                         tmpfs   32985848        0   32985848   0% /dev/shm

Any thoughts on what I’m missing or doing incorrectly here?


(Matthieu Aubry) #2

Just enable DB session: Installation - Analytics Platform - Matomo


#3

[quote=matt]
Just enable DB session: Installation - Analytics Platform - Matomo

Hey Matt,

Thanks for your reply and the assistance in my other thread. I previously followed the steps as advised and am still receiving the same error.

Previously:


# grep session_ config.ini.php 
session_save_handler = "dbtable"

Currently:


# grep session_ config.ini.php 
;session_save_handler = "dbtable"
session_save_handler = dbtable

Even with this configuration, I am still receiving the following notification in the System Check:


Your server is using an NFS filesystem.
This means Piwik will be extremely slow when using file based sessions.

Any other thoughts/suggestions?


(Fabian Becker) #4

It’s not an error - just a warning. Since you configured db-based sessions everything will be fine. If you read the message carefully it reads: “[…] will be slow WHEN using file based sessions”


#5

[quote=“Fabian Becker”]
It’s not an error - just a warning. Since you configured db-based sessions everything will be fine. If you read the message carefully it reads: “[…] will be slow WHEN using file based sessions”[/quote]

Hey Fabian,

Thank you for taking to time to reply and your insight. I know it may seem irrelevant, however if I’ve configured Piwik to use db-based sessions, shouldn’t it remove the warning, or advise further that I’ve added a configuration that should ‘correct’ the warned issue.

On another note, what could I have done to prevent the issue from the being? What ‘NFS Filesystem’ am I using, and which ones are supported that I should have chosen/setup instead?

Thanks again for your time.


#6

[quote=phasicllc]

[quote=matt]
Just enable DB session: Installation - Analytics Platform - Matomo

Hey Matt,

Thanks for your reply and the assistance in my other thread. I previously followed the steps as advised and am still receiving the same error.

Previously:


# grep session_ config.ini.php 
session_save_handler = "dbtable"

Currently:


# grep session_ config.ini.php 
;session_save_handler = "dbtable"
session_save_handler = dbtable

Even with this configuration, I am still receiving the following notification in the System Check:


Your server is using an NFS filesystem.
This means Piwik will be extremely slow when using file based sessions.

Any other thoughts/suggestions?[/quote]


#7

I agree and the warning should not be shown if db-based sessions are activated. Please fix it.

And by the way. Since when is EXT4 a NFS-Filesystem?
I think your FS-Check is buggy.
Since the upgrade to version 2.14.2 the PHP-function shell_exec is needed.
After activating the function the warning for the NFS-Filesystem is shown.

And now your forum thinks that I am a bot. Best morning ever…sorry for that.


(Matthieu Aubry) #8

Hi there,

I agree and the warning should not be shown if db-based sessions are activated. Please fix it.

I think it would work. can you create an issue on our tracker? Issues · matomo-org/piwik · GitHub

And by the way. Since when is EXT4 a NFS-Filesystem?
I think your FS-Check is buggy.

Our check is: piwik/Filesystem.php at 2.14.2 · matomo-org/piwik · GitHub

can you paste the output of this command for you?


#9

I agree and the warning should not be shown if db-based sessions are activated. Please fix it.
I think it would work. can you create an issue on our tracker? [github.com]
Issue created: Suppress warning for NFS-filesystem if db-based sessions are activated · Issue #8498 · matomo-org/piwik · GitHub

And by the way. Since when is EXT4 a NFS-Filesystem?
I think your FS-Check is buggy.
Our check is: [github.com]
can you paste the output of this command for you?


root@SERVER:~# df -T -t nfs /var/www/XXX/tmp/sessions/
df: no file systems processed

root@SERVER:~# df -T -t ext4
Filesystem                                             Type 1K-blocks      Used Available Use% Mounted on
/dev/disk/by-uuid/FOO ext4 123 123 123  12% /


(Matthieu Aubry) #10

Thanks for the report. The check should be fixed with this patch in this issue System check diagnostic for "Filesystem" may detect wrong filesystem used · Issue #8525 · matomo-org/piwik · GitHub

let me know if after applying the patch you still have the problem