Syntax error - unexpected ''Country_BQ'


my Piwik installation worked fine till today. Now i just get an error when trying to access the Piwik dashboard. It says:
An error occured
syntax error, unexpected '‘Country_BQ’ (T_ENCAPSED_AND_WHITESPACE), expecting ‘)’

My server shows me similar error messages every few minutes in the log:
Either this

mod_fcgid: stderr: Error in Piwik: syntax error, unexpected ''Country_BQ' (T_ENCAPSED_AND_WHITESPACE), expecting ')'

or this

mod_fcgid: stderr: Error in Piwik: syntax error, unexpected ''Country_BQ' (T_ENCAPSED_AND_WHITESPACE), expecting ')', referer: https:/

Does anybody got an idea whats is causing this and how to fix it? Is it the server config (Apache and NGINX, an Piwik plugin or just a corrrupted file? Or maybe even a hack??

Your advise will be much appreciated!



I haven’t seen this error before.
Doesn’t the error log often show in which file and line the error occurs?

One thing I can think of is deleting the content of the top folder which instructs Piwik to regenerate the cache.

Thanks for you answer.
Unfortunately, this specific error message doesn’t show in the log which file it relates to or path or line it occurs. There were different PHP related error messages also related to PIWIK the week before but it seemed to be away for 5 days until this error occured and made PIWIK break.

Can you define more precicesly which folder to delete as proposed?

I tried to reinstall PIWIk to solve this error.

Reinstallation worked fine but in the end after a successfull process it shows me this error again.

I can’t find anything about this error in the net nor in the forum.

Please, any advice or steps i can go through to drill down what this is causing?


Maybe I get an idea help if you provide more details. Are you using any third party plugins? Which geolocaliation module are you using? How did you reinstall piwik? Have you deleted the cache? (In the same folder where you can find the piwik.php and the plugins folder there should be a folder called tmp. You can delete everything in it, it will be regenerated)
Are you by change using the Ip2location plugin?


thanks much for your help. I don’t know how but the error disappeared. After reinstalling itried various things and then was able to get at least the login screen. The password and username was not correct it howed me so i made some changes in the database and in the end i was able to access the dashboard again.
No idea what it was.


1 Like