Superuser - Can't login and no error message :S


#1

Hello,

I updated from Piwik 1.1.1 to 1.2 with backing up config/config.ini.php and config/global.ini.php and deleting then all files and uploading the new files
and restore the config.ini.php and global.ini.php.

Then I run the update and it successful updated.
Then I got the Login form but this doesn’t work.
If I try to login with my login data it doesn’t show an error or something,
it just shows me the login form again.
I already tried “Forgot password” and it says it changed
but this doesn’t work too.

Please help =/


(Matthieu Aubry) #2

Are you behind a reverse proxy or a special configuration maybe? Installation - Analytics Platform - Matomo

was it working fine before upgrade?


(vipsoft) #3

Please use the global.ini.php from the 1.2 release.

Also, read this changelog.

The configuration setting, “reverse_proxy”, has been renamed to “assume_secure_protocol”. If your config/config.ini.php contains “reverse_proxy=1”, simply change this to “assume_secure_protocol=1”.


#4

OK, I set the “assume_secure_protocol = 1” like mentioned, but after I changed it now to “assume_secure_protocol = 0” it works now :)! Thank you for your awesome work!