Sudden error with ajax.php


#1

Without any update or change from my side I get an error about ajax.php after logging in.
The mobile-app gets an error, too.
Any suggestions?


There is an error. Please report the message (Piwik 2.5.0) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined variable: _POST in /mnt/web1/e3/63/51136263/htdocs/Piwik_02/plugins/UserSettings/Reports/ajax.php on line 1

Backtrace -->

#0 Piwik\Error::errorHandler(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/plugins/UserSettings/Reports/ajax.php:1]
#1 require_once(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/Plugin.php:448]
#2 Piwik\Plugin->doFindMultipleComponents(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/Plugin.php:364]
#3 Piwik\Plugin->findMultipleComponents(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/Plugin/Manager.php:316]
#4 Piwik\Plugin\Manager->findMultipleComponents(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/Plugin/Report.php:610]
#5 Piwik\Plugin\Report::getAllReports(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/Menu/MenuReporting.php:114]
#6 Piwik\Menu\MenuReporting->getMenu(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/plugins/CoreHome/Controller.php:134]
#7 Piwik\Plugins\CoreHome\Controller->getDefaultIndexView(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/plugins/CoreHome/Controller.php:167]
#8 Piwik\Plugins\CoreHome\Controller->index(...) called at [:]
#9 call_user_func_array(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/FrontController.php:576]
#10 Piwik\FrontController->doDispatch(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/FrontController.php:86]
#11 Piwik\FrontController->dispatch(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/core/dispatch.php:34]
#12 require_once(...) called at [/mnt/web1/e3/63/5********/htdocs/Piwik_02/index.php:47]


(Matthieu Aubry) #2

ajax.php is NOT a piwik file !
Unfortunately it looks like a malware/virus on your server.
What other software do you use?
maybe one has been compromised. Can you check and let me know more info?

See our recommendations: How to configure Piwik for security - Analytics Platform - Matomo