Styles and Widgets broken after update to 1.1


#1

Hello there,
I just did the update to Piwik 1.1 from 1.0 using the builtin update routine. The updater said all went fine. But after logging in I now get the sites without any styles applied, meaning it’s just plain text (as if CSS was deactivated, which it isn’t). Also all the dynamic/Ajax functions are not working anymore (e.g. I see no widgets on the dashboard). I already tried to do the manual update but it gets the same results.
Does anyone have an idea what might have gone wrong here?
If you need more info I will gladly provide it.


(Matthieu Aubry) #2

few things you can try

  • clear your browser cache
  • delete the content of your piwik/tmp/assets/
  • try with a different browser

if you still have the issue please send by PM your piwik URL + login + password + bug description


#3

Followup info:

Seems the problem is with the js/css merging code. As soon as I enable the disable_merged_assets options in the [Debug] Section of the config the site starts working again. I’ll leave it on for now to have a working piwik, but I’ll be glad to test any fixes/patches if there are any.

/seiichiro0185


(vipsoft) #4

Can you pm your phpinfo to either matthieu or myself?


(daniol) #5

I have the same problem and was fixed editing config/global.ini.php and setting

disable_merged_assets = 1

I’ve PM’ed my phpinfo();


#6

I also PM’d my phpinfo, hope it helps to fix this :slight_smile:


(vipsoft) #7

thanks. looking into it now.


(vipsoft) #8

Ok. Because the AssetManager does its own compression, it isn’t compatible with your existing compression settings.

These can only be disabled using php.ini, .htaccess or httpd.conf, so I don’t have a code fix.


output_handler = ob_gzhandler


auto_append_file = gzip_end.php
auto_prepend_file = gzip_start.php


(Matthieu Aubry) #9

Anthon, could we detect that compression is enabled and not compress the assets when this is the case?

I see that you already created a ticket, cool Detect output compression conflict · Issue #1940 · matomo-org/matomo · GitHub


(vipsoft) #10

During installation, could send compressed and uncompressed files to the browser, and have it send back a response whether or not they match.


(daniol) #11

Yea, that should be the problem. gzip_start minify and compresses all my js and css

Gzip automatic detection should be the trick.


(vipsoft) #12

daniel: in gzip_end.php, do you check to see if the content-encoding header has been set?


(Matthieu Aubry) #13

seiichiro0185, set


[General]
disable_merged_assets = 1

in your config/config.ini.php to disable the assets merging for now. Hopefully we can detect if gzip is enabled and not compress the assets.

Please continue the technical discussion (and future patch testing) on the ticket at: Detect output compression conflict · Issue #1940 · matomo-org/matomo · GitHub


#14

I have set this (actually since yesterday, but seems It wasn’t that clear from my followup post :slight_smile: ) and its working for now. Thanks again for your really fast reply!