Stupid admin bug! -- SyntaxError: expected expression, got end of script


I’ve got a REALLY annoying bug :frowning:

At first, I thought I must have been corrupting it somehow (not sure how, but the fact it did it a couple of times in a row … but I’m not sure thats the issue now, as it literally did it right after a fresh install, and then forced reload)

Way to replicate:

  1. Install Piwik, and then setup the tracking.
  2. Go to the admin panel… all good (loads).
  3. Then, do a forced reload… and I get a horrible error:

SyntaxError: expected expression, got end of script

index.p…a902ada (line 13, col 32011)ReferenceError: $ is not defined
$(function () {

Here is a screenshot of FF and Firebug alongside each other. As you can see, all the main content is blank - and there are 2 big fat nasty errors:

Any suggestions? I’ve tried doing full removal, re-install, etc etc… 3 times… and every one of them has the same issue. Damn annoying :frowning:



can you try to delete piwik/tmp folder and try again?

can you check your Administration > System check that there is no error/warning?


Sorry - I didn’t get notified of this reply.

In System Check, I have a few small errors - but no biggies:

Renaming the /tmp folder to /tmpfoo , and then re-running the admin panel homepage - I get the exact same error message :frowning:

I contacted my tech, and it looks like it was a permissions issue in nginx php-fpm:

2016/04/28 19:12:35 [crit] 7490#7490: *97849 open() “/var/cache/nginx/fastcgi_temp/2/30/0000001302” failed (13: Permission denied) while reading upstream, client: x.x.x.x, server:, request: “GET /track/index.php?module=Proxy&action=getCoreJs&cb=f0fea36ab05ecd293371cf35fa902ada HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “”, referrer: “

Set them correctly, and seems to be working well now