Strange display of an SQL Entry in "security settings"


(Tomcraft) #1

Hi @ all,

I get a strange display on top of the security-page:

a:4:{s:12:"announcement";b:1;s:6:"source";a:2:{i:0;a:4:{s:8:"filename";s:17:"php-5.3.2.tar.bz2";s:4:"name";s:19:"PHP 5.3.2 (tar.bz2)";s:3:"md5";s:32:"46f500816125202c48a458d0133254a4";s:4:"date";s:11:"04 Mar 2010";}i:1;a:4:{s:8:"filename";s:16:"php-5.3.2.tar.gz";s:4:"name";s:18:"PHP 5.3.2 (tar.gz)";s:3:"md5";s:32:"4480d7c6d6b4a86de7b8ec8f0c2d1871";s:4:"date";s:11:"04 Mar 2010";}}s:4:"date";s:11:"04 Mar 2010";s:7:"version";s:5:"5.3.2";}

I didn’t find that in the database, so where does it come from?! style_emoticons/<#EMO_DIR#>/huh.gif

Best regards

Tom


(vipsoft) #2

It looks like a bug in your php build. What version are you running?

(The output you see is the response from php.net. It shouldn’t be output to the screen.)


(Marbot) #3

I experience the same on my installation. I’m running on PHP 5.2.12.

Edit:

You are running PHP 5.2.12. The latest version of PHP is 1.

I do not use any extras as eAccelerator etc. etc.


(Tomcraft) #4

Thx for your reply,

this is my PHP version:

You are running PHP 5.2.6-1+lenny8. The latest version of PHP is 1.

I’m using eAccelerator, is that a problem?

Best regards

Tom


(vipsoft) #5

More weirdness? Please PM your phpinfo.

This was tested on 5.1.6, 5.2.6, 5.2.11, and 5.3.2, so it might be configuration related.


(Marbot) #6

[quote=vipsoft @ May 29 2010, 06:53 PM]More weirdness? Please PM your phpinfo.

This was tested on 5.1.6, 5.2.6, 5.2.11, and 5.3.2, so it might be configuration related.[/quote]

I am on shared hosting and have limited control of my php sttings: http:// www.phpinfo.he-webpack.de/phpinfo.php
These are the settings I may control together with the current settings:
PHP-Errors - Nur ins Logfile schreiben
PHP-RegisterGlobals - Off
PHP-mbstring.func_overload - Serverstandard
PHP-allow_url_fopen - On
PHP-allow_url_include - Off
PHP-Magic-Quotes-GPC - Off
PHP-Zend-ZE1-Kompatibilität - Off
PHP-Register-Long-Arrays - Off
PHP-Session-Use-Trans-SID - On
PHP-Allow-Call-Time-Pass-Reference - Off
PHP-MySQL-Secure-Login - On
PHP Suhosin Executor Allow Symlink - Serverstandard
PHP Suhosin Session Encryption - On
PHP Suhosin Mail Protection - 2
PHP Suhosin RPG Max Vars - Serverstandard

Hopefully this is what you requested.

Cheers


(vipsoft) #7

This should now be fixed in the latest version of core/Http.php.

http://dev.piwik.org/trac/export/2242/trunk/core/Http.php


(Marbot) #8

Affirmative! Thank you for your help in this case! Cheers


(Tomcraft) #9

THX for the fix! Works great. :wink:

Best regards

Tom