Step 6 Timezone install error

Sorry but i don’t understand

as follow i should select a timezone but i don’t have a input zone for this

Some ideas ?



This is a major bug in the recent piwik version which hasn’t been solved as nobody from the piwik team is able to reproduce it:

You should be able to work around it by using another browser than Firefox, but please help us reproduce it, so it can finally be fixed.

Which PHP Version are you using?

What os are you using for the server?

I run piwik on an alpinelinux with nginx

You can fin my phpinfo :

My bug is with chromium
Version 62.0.3202.75 (Official Build) Built on Ubuntu , running on LinuxMint 18.2 (64-bit)

I can do all test you want.
It’s in a Virtual Machine

Yes the bug can be pass with firefox, but i didn’t have a good css


Many thanks for the info.

Just to make sure it isn’t another issue:

Do you have any adblocker enabled? Can you check if any requests in the network tab of the browser are failing?


The first time i tried to install i had this error despite the step 4 validation
I’d just drop the database and start again

Now i try again for the test i got it too

I just put it in case …


I think this error is unrelated No more room in record file seems to be a MySQL side-error.

But this time i don’t know how to pass this error the first time,
I have it again and again …

I will stop loking for the moment …

So my sql error is just a full disk on my VM.

But so i can have the timzone error again
And i have the error with firefox too.

As you can see ublock is desactivate

But on the first copy/past the css didn’t load and it was possible to select the timezone
when i refresh get this screeen

This is what i get after clean the cache, ublock activate and reload nothing else

And new error link



Can you check the developer tools of your browser and see which errors occur in the javascript console. The new errors seem to be that javascript and CSS fail to load.

Maybe disable uBlock again as it tries to block all data on domains starting with piwik.

with the console error

hope this help


I tried accessing the site and in firefox I am getting the same error (After disabling ublock). A Javascript file ( fails to load without an obvious error.

But when I open it in Chrome it displays that this request fails with an net::ERR_SPDY_PROTOCOL_ERROR. Oddly when I try to access the url directly it works.

What version of nginx and http2/spdy module are you using? Can you check the webserver error log if it shows any reseason why the SPDY connection is failing?

Maybe try disabling http2/spdy temporarily to check if it fixes the error.

I passed some time the check this errors,
It’s an error with my nginx reverse proxy but i don"t have this errors on my other website.
I need some time to look after, and replay


1 Like

The trouble come from my reverse, i try i new install and everything was fine.