Stats no longer registering


(brandonk) #1

For some reason, stats are not picking up anymore.

I thought at first it was the plugin I had with WordPress, but it happens with integrated code now as well.

It was working fine on the first day, I didn’t add or uninstall anything and all the plugins I disabled/enabled I went back to like it was before I did that and still no go.

Anyone else experiencing this? Can I send info to an admin to get some help on this issue?


(ishkey) #2

Same problem with data, but my site is not WP, just plain html/css -
I installed on 9-12-09 ran until 9-19-09 with no problem.
My site does not receive enoungh visitors to overload the system. Nothing has change, but no more data is being processed.
Does any body have a clue to this.
Looked in error log showing

[13-Sep-2009 04:09:11] PHP Warning:  parse_ini_file(/home/wilmargr/public_html/cleandeck/piwik/config/config.ini.php) [<a href='function.parse-ini-file'>function.parse-ini-file</a>]: failed to open stream: No such file or directory in /home/wilmargr/public_html/cleandeck/piwik/core/Tracker/Config.php on line 61
[13-Sep-2009 04:09:11] PHP Warning:  Invalid argument supplied for foreach() in /home/wilmargr/public_html/cleandeck/piwik/core/Tracker/Config.php on line 64

[25-Sep-2009 08:13:26] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'plugins/SearchEnginePosition/DataFiles/SearchEngines.php' (include_path='/home/wilmargr/public_html/cleandeck/piwik/core:/home/wilmargr/public_html/cleandeck/piwik/libs:/home/wilmargr/public_html/cleandeck/piwik/plugins') in /home/wilmargr/public_html/cleandeck/piwik/plugins/SearchEnginePosition/SearchEnginePosition.php on line 118
[25-Sep-2009 09:11:18] PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 3145728 bytes) in /home/wilmargr/public_html/cleandeck/piwik/plugins/GeoIP/libs/geoip.inc on line 317
[25-Sep-2009 09:11:22] PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 3145728 bytes) in /home/wilmargr/public_html/cleandeck/piwik/plugins/GeoIP/libs/geoip.inc on line 317

(ishkey) #3

Ok check all the files they are there. Did a forced re-install. Went through all the FAQ and troubleshooting. Still the problem is there.
Does anyone have any other solutions short of deleting everything and starting over?


(vipsoft) #4

ishkey: in your case, your hosting provider capped the memory limit for a running PHP script at 32M; you can try increasing this in your php.ini, .htaccess, or bootstrap.php.


(ishkey) #5

You were right. I was capped at 32M. Increased the php.ini to 64M. Problem solved.
Thanks for your help - for a minute I thought I was losing it.
Something so simple that you don’t think about.
Again thanks.


(brandonk) #6

Ok I figured out my problem, piwik defaults to the day before on stats?

Is there a way I can default it to the day im viewing it?

My server time is the same as my local time, so I know its not that.


(vipsoft) #7

brandonk: see the config.ini.php override example at http://dev.piwik.org/trac/wiki/API/IncludePiwikInYourProject


(brandonk) #8

I did that and its still defaulting to the day before.

Do I need to restart anything?