Statistiken auf 0 nach Token-Neueingabe (WP)


#1

Hallo,

wir sind heute mit einen Shop gelauncht - hatten Piwik aber bereits ein paar Tage installiert und am laufen.

Es gab 2 eingetragene Seiten : ‘edelmix.de’ und ‘edelmix.de/em2015/’ (letzteres war die Setup-Adresse vor dem Launch - hat aber auch keine Daten generiert)

Nun haben wir heute die Seite ‘edelmix.de/em2015/’ (unter Piwik) gelöscht, da die Daten / die Seite nichtmehr von nöten sind / ist.

In Wordpress schienen keine Daten mehr anzukommen, bzw. das Plugin hat keine mehr gezeigt. Daraufhin haben wir nochmals den Auth Token kopiert, in WP eingelassen und gespeichert. Die Daten werden, soweit wir das bis jetzt sehen können, wieder erfasst - allerdings wurden auch alle Daten zurück auf Null gesetzt.

Typischer Anfänger-Fehler? Setzt ein wiederholtes Einfügen des Token alle Daten zurück?

Oder wird eine neue Datenbank angelegt?

Danke für Eure Hilfe & Gruß / Sascha


(Stefan Giehl) #2

Der Token sollte eigentlich nur verwendet werden um die Daten auszulesen?
Werden die Statistiken denn korrekt angezeigt wenn du dich direkt in Piwik einloggst?


#3

hallo,

soweit alles gut - wir haben anscheinend nur den ersten tag ‘verloren’.

allerdings habe ich gerade das plugin-update in wp durchgeführt - danach muss man piwik wieder verbinden. ist das normal?

danke & gruß / sascha


(Stefan Giehl) #4

Ob das normal ist kann ich nicht sagen. Das ist denke ich eine “eigenheit” des Wordpress plugins. An Piwik selbst ändern sich diesbezüglich ja nichts.
Vllt werden die Verbindungsdaten (token_auth, username, passwort, o.ä.) nur temporär im cache gespeichert und gehen bei einem Update so verloren.