SSLv3 blocks Matomo


#1

Hello Guys, under my domain www.moebel-boeck.de/matomo/ id install the latest version. After using the WP-Piwik plugin for the site id like to connect it. But i received the following error:
error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

My support answered:
Unfortunately the SSLv3 was stopped a long time ago and we cannot enable it due to we not longer support it.

The alternative in this case is to contact the plugin’s support so they can try to change the used SSL version via which the Piwik plugin connects.

if you encounter any other difficulties do not hesitate to reach su back!

Any ideas, guys?


(Peterbo) #2

Your server seems to fallback to a SSLv3 handshake. Which OpenSSL version is running on the server? (phpinfo())

If you know a bit of coding, you can try to force a TLS1.2 connection with cURL:

curl_setopt($ch, CURLOPT_SSLVERSION, 6);

If this runs without hassle, we’ll have to figure out why the connection is falling back to SSLv3.


(Fabian Dellwing) #3

Just to be sure, Matomo is not the author of the WP-Piwik plugin!

I’m also really sure that this is not an error of the plugin, but of the server it is running on. SSLv3 should be disabled for outgoing and incoming connections. So check your OpenSSL version and check your PHP version.

From the answer from the support I guess your Matomo and your WP site are running on two different servers?


#4

Thx guys for your answers :slight_smile:

Matomo runs on the same server as the website. Just the Domain is on a different host.
With other installations i got no problem. Just in that specific case…

Got still no solution and try to fix it :-/