SSL Proxy Setup Breaks Login (and more)


#1

Hello,

I recently upgraded to PW 2. It seems that the SSL-Proxy setup makes problems. Under PW 1 there were several problems too, but now some more and serious are added:

Given:
A domain that has a .htaccess with a RewriteEngine On (according to 1&1 specs).
Calls to that URL work as they should and forward >
http://www.thetrial.de[/url] forwards to [url=https://ssl.kundenserver.de/thetrial.de/]https://ssl.kundenserver.de/thetrial.de/

PW 1.x worked more or less but always (!) missed the own set branding logo. This was the most persistent problem with this ssl proxy forwarding, not to fix.

PW 2.x now has the same problem and in addition: I does not show the small graphs on the first dashboard page. Only these are missing there. Other graphs works.
But the big problem ist: A Piwik login leads to ssl.kundenserver.de/piwik instead of ssl.kundenserver.de/thetrial.de/piwik. This is not good! Those logins happen via a subdomain. After a mislead login a second call of that url leads to Piwik. This did not happen with PW 1.

So where could be the bug? And how is this ssl proxy issue to fix?


(Matthieu Aubry) #2

It sounds like a bug indeed, but it works for us.

Are you using PIwik 2.3.0 ?


#3

I guess so, yes. I updated yesterday. Hm, actual Piwik does not show its version in the right upper corner as it once did (did it?).

After the update this problem occured. So I decided to move the whole /piwik directory and start from scratch with a new install. But – it was the same. I set up Piwik for several other sites, too, all together at 1&1. But those other projects are simple http-sites. This all works. But the ssl-proxy of 1&1 seems unmanageable for Piwik :-/

Greets.


#4

Uh-oh, PW2 also often does not show the whole sites (loading, loading, loading, then 0 of 0). Is there a step-by-step guide to go back o PW1? PW2 is not what I can handle. But when going back to PW1, there is a md5 hash problem occuring when I want to login :frowning: Very bad.

Greets.


(Matthieu Aubry) #5

@pfbatt if you have a problem with Piwik 2, please report the bug here,. What is the problem exactly? can you post some screenshot?

PS: It is not possible to go back to Piwik 1


#6

I have reported the bug (above)?

When I call the login page of piwik it does not redirect me to the right place anymore. This did not (!) happen under PW 1. This is the main bug. The problem seems to be that piwik cannot handle the ssl-proxy anymore. It redirects me to the main ssl-proxy URL, though this is not a site-based one.

Another, new, bug is, that I (often but not everytime) don’t see my sites at the »all sites« dashboard. This stays clear and cliams 0 of 0 sites. I then can directly move to one site, and from there chose other sites (sum of 7 sites). This happened exactly one day after the update. The first day all worked. Strange.

If you want, I can set up a guest login account for you to experiment.

Nice weekend.