SQLState Error after Upgrading from 1.x Version to Latest Version


#1

Dear all,

i am having a problem after upgrading from a around 3-4 years old version to the latest DL Version of Piwik.
On the day of installation all was running fine, also I got timeouts during Database Upgrade, at the end of the installation the system said all installed sucessfully! Login was working and I was able to see almost all widgets working. But yesterday, I got the error:

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘log_action.url_prefix’ in ‘field list’

On almost all widgets…

So I guess the database upgrade failed somehow.

What is the right way, to fix the problem. I saw there is an option to restart the database upgrade manually, but now i am not sure, which version we had before. I know it was a 1.x , but how can i find out?

I have the old config.ini.php and functions.php, but do i find the Version Number in it?

Thanks for the help!

Dennis


(Matthieu Aubry) #2

Hi Dennis,

Please find some information on this FAQ: After the update, I get sql errors, I would like to try the update again. How do I force Piwik to re-upgrade the database from a past version? - Analytics Platform - Matomo


#3

Dear Matt,

yes I already checked this, but what can I do, when I am not sure, if we were using 1.4 or 1.8 before?
Or wont it be a problem?

Best Dennis

I tried to manually recreate the database via php /srv/www/kludi.com/piwik/console core:update
But still not working, i also installed the new version and still getting the error:

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘log_action.url_prefix’ in ‘field list’

Any suggestions?