SQLSTATE [28000] since 2.1.0 Update


(Nosferatuvn) #1

Hello,

i installed the update 2.1.0 -> works all ok

But i have now on some tabs this error


INFO Actions[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user 'web1'@'localhost' (using password: YES)[28000]
INFO Actions[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user 'web1'@'localhost' (using password: YES)[28000]
INFO Actions[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user 'web1'@'localhost' (using password: YES)[28000]
INFO Referrers[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user 'web1'@'localhost' (using password: YES)[28000]
INFO Referrers[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user 'web1'@'localhost' (using password: YES)[28000]
INFO Referrers[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user 'web1'@'localhost' (using password: YES)[28000]
INFO Referrers[2014-03-20 15:43:19] [72999] LOAD DATA INFILE failed... Error was: SQLSTATE[28000]: Invalid authoriz

Can someone help me ?

Best Regards
Nosferatuvn


#2

Go through the fixes in this FAQ: How do I get LOAD DATA INFILE to work on my server? - Analytics Platform - Matomo

I had the same issue and it was finally fixed by modifying the apparmor settings.


(Nosferatuvn) #3

Hi,

thank you for your answer.

I am not server admin … so i can’t check the mysqld and so … and the piwik user is ok, i checked my user.

I can only do the second, i have change von php 5.3 to 5.4
change to adapter=MYSQLI

and open_basedir and safe_mode are disable

but it don’t work.

If I have MYSQLI on the widgets are only “loading widget, please wait”

Is there an other method ?


(Nosferatuvn) #4

sorry for double post … but i can’t edit the post …

If fix it, thank you :slight_smile:

in the config.ini.php is

schema = “Myisam”

If i delete it and add adapter=“MYSQLI”

it works now !