SQLSTATE[28000] [1045] Access denied for user


#1

Hi,

i tried to update my 1 year old installation and after that process the following error occured:

SQLSTATE[28000] [1045] Access denied for user ‘xxx’@‘localhost’ (using password: YES)

I saved the config.ini.php file and had to reupload it, because the password got lost.

The logincredentials are correct and working. They did before und i tested it on my other sites and via direct login.

After that i uploaded a the latest version via ftp, set the the owner to my serveruser and added the logincredentials but still the same result.

Any ideas?

Kind regards

/edit
I copied all the tables to a new database and set a new user with just letters as pwd, still not working.


(Zachary Goldsmith) #2

Did you make sure to prefix the tables as before? Usually the default is piwik_


(Zachary Goldsmith) #3

Also to be sure the xxx@localhost has access to the new database created.


(Stefan Giehl) #4

Does your mysql password has any very special chars or stuff like a whitespace in the beginning or in the end?


#5

Hi, yes prefix is set to “piwik_”.
New password only contains capital and small letters, old one had special chars, but they worked before the update took place.
Yes the new user has access, the access via e.g. phpmyadmin works. At first the superuser was used, that one did not work either.

/edit
Setup a new installation and copied the old database afterwards. Had to remove several plugins and update the superuser in the db, but now it works. Old way still not working, dont know why.