Soucis sur le code de suivi


(Arnaud Launay) #1

Bonjour,

La dernière fois (il y a, pfou, longtemps, probablement la version 1 de piwik) que j’ai pris le code de suivi pour l’intégrer dans une page, il m’avait donné ça en cliquant sur code de suivi (commandes paq_push supprimées):


<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  (function() {
    var u=(("https:" == document.location.protocol) ? "https" : "http") + "://piwik.cusae.com/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    var d=document, g=d.createElement("script"), s=d.getElementsByTagName("script")[0]; g.type="text/javascript";
    g.defer=true; g.async=true; g.src=u+"piwik.js"; s.parentNode.insertBefore(g,s);
  })();
</script>
<!-- End Piwik Code -->
<noscript><div><img src="https://piwik.cusae.com/piwik.php" style="border:0" alt="piwik" width="0" height="0" /></div>
</noscript>
<!-- /Piwik -->

Le problème, c’est que là depuis j’ai mis à jour régulièrement par la méthode automatique, donc je suis en 2.7… Et je viens d’ajouter un nouveau site, je suis donc allé chercher le code de suivi…


<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//piwik.cusae.com/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//piwik.cusae.com/piwik.php?idsite=XXX" style="border:0;" alt="" /></p></noscript>
<!-- End Piwik Code -->

Donc


    var u="//piwik.cusae.com/";
<img src="//piwik.cusae.com/piwik.php

Ya pas comme un soucis, genre il manque un peu http et/ou https ? J’ai raté quelque chose quelque part au niveau config ?


(Arnaud Launay) #2

Bon, j’ai fini par trouver, apparemment c’est une feature et pas un bug:

Issue 344

J’aurai appris un truc, désolé du bruit !