Some tables in your database have the same names as the tables Piwik is trying to create


#1

Hi I was moving the piwik installation to a new folder so i deleted the old one it was version 2 i think, and download the latest version and uploaded it and started the installation but its now saying Some tables in your database have the same names as the tables Piwik is trying to create.


(Matthieu Aubry) #2

Does it let you “Reuse the table” or do you only see the option to “Delete the tables” ?


#3

I tried this myself, no option to re-use or skip that table name collision (only option is to go back and set a new prefix, create new tables then manually edit the config file back to your old prefix)


(Dan Poynor) #4

I have this same issue.

There is no option to re-use the existing tables.

I figured out I can copy config.ini.php from my previous piwik install to the new one and everything works though.


#5

There was no option to “Reuse the tables”…

I have fixed the problem:

Backing up my database tables first.
reinstalling piwik Deleting the tables when prompted.
Then importing the backup tables.


(Matthieu Aubry) #6

Thanks for the report that “Reuse DB Tables” option is not displayed anymore. I created a ticket at no option to “Reuse the tables” when reinstalling Piwik · Issue #4562 · matomo-org/matomo · GitHub and we’ll fix this bug!


#7

I think my situation may be similar to the above. The short story is that I suddenly got a blank page when trying to access piwik (version 2.0.3). I tried deleting the config.ini, but no joy, so I proceeded with a reinstall. The reinstallation did not propose using the existing tables, and only allowed to either to overwrite or go back to the previous step and change the table prefix. I opted for the latter, so I now have two sets of tables (old set prefixed with “piwik_” and new set prefixed with “pwk_” ) with piwik using only the new tables. Is there a way to get the data in the old tables into new tables that the new piwik installation can use?


#8

As I stated above the same applies and should work (admin correct me if im wrong) export/save you old tables then import the tables to your new database I used mysqladmin some people use phpmyadmin.


(Matthieu Aubry) #9

This bug was fixed in: https://github.com/piwik/piwik/commit/0371500b18f9d2944232791c11907be986b49882d

thanks for the report!