[Solved] WebCron does not work / Archive via browser seems to be broken


(Christian) #1

Hi Community,

I’ve got some problems with Piwik lately.

  • I don’t have access to setup a “real” cronjob, I did the archiving always via webcron. But now - when testing the webcron via browser I get an error message I don’t understand:

You must specify the Super User token_auth as a parameter to this script, eg. ?token_auth=XYZ if you wish to run this script through the browser.

Well that is what I do: The URL I’m calling seems to be right:


http://my.piwik.domain.com/misc/cron/archive.php?token_auth=1234567890

… and 1234567890 is the API Key from my super users account. So what to change? Small side question: On the API page the key is given with a leading ‘&’:


&token_auth=1234567890

, NOT with a ‘?’, but it makes no difference, the error occurs anyway.

  • As workaround I tried the archiving via browser, but that seems not to work too: No data in the graphs for the most sites, but I can see the visitors log is filled with data.
    Can anybody point me in the right direction?

My setup:
Piwik 2.9.1
shared hosting enviroment
All green in Settings -> Systemcheck
But: No LOAD DATA INFILE at all (I’ve turned it off via config)
150 low traffic sites are tracked.
30 sites get data in the graphs, the rest stays empty.

Thanks a lot.
Chris


(Matthieu Aubry) #2

Hi there,

It’s strange the archive.php web cron does not load with your Super User token. I just tested it and it works fine for me. Could you try again or with a nother super user token auth?


#3

Check out a tutorial at https://www.easycron.com/cron-job-tutorials/how-to-set-up-cron-job-for-piwik, maybe help you.


(Christian) #4

Hi! Thanks for taking the time to look into this.
I created a new user and gave hime SU rights. Then I logged into Piwik to find the new token for that user. After that I tried to run the webcron via browser, but I still get the same message.
If you want to look for yourself I could send you a PM with the token and the link. If that would help…


(Christian) #5

I’ve setup a cronjob at www.easycron.com and tested it (manually).
Though the easycron system tells me that the cronjob had “succeeded”,

Start Time: 2014-11-24 07:11:16
End Time: 2014-11-24 07:11:16
Connect Time (second): 0.111495
Total Time (second): 0.399507
HTTP Code: 200
Status: Succeeded

the reply of it is just the same:


HTTP/1.1 200 OK
Date: Mon, 24 Nov 2014 07:06:19 GMT
Server: Apache/2.2.22 (Debian)
Vary: Accept-Encoding
Transfer-Encoding: chunked
Content-Type: text/html

<b>You must specify the Super User token_auth as a parameter to this script, eg. <code>?token_auth=XYZ</code> if you wish to run this script through the browser. </b><br>
                    However it is recommended to run it <a href="....">via cron in the command line</a>, since it can take a long time to run.<br/>
                    In a shell, execute for example the following to trigger archiving on the local Piwik server:<br/>
                    <code>$ /path/to/php /path/to/piwik/console core:archive --url=http://your-website.org/path/to/piwik/</code>

Maybe that is just the normal reply?


(Matthieu Aubry) #6

It is not the normal reply, why dont you try to load it via HTTP directly? it should load for you the core:archive output. If it really does not work fory ou with Piwik 2.9.1 then please create an issue on Issues · matomo-org/piwik · GitHub


(Christian) #7

Thanks Matt!
Please specify what it means when you write

why dont you try to load it via HTTP directly
.
I don’t understand that because I thought calling the URL via browser is in fact loading via http. What else can I try? Sorry, I don’t have a clue right now.
Thanks,
Chris


(Matthieu Aubry) #8

can you please email me at matt @piwik a link to this forum post, as well as the URL with your token_auth ? (I will not share it with anyone of course and you can change it afterwards)


(Christian) #9

@Matt: I’ve sent the email just a second ago.
Thank you very much.
Chris


(Christian) #10

Hi there,
any news on this?


(Christian) #11

Solved!
Thanks to Matt.
issue 1
issue 2