[SOLVED] Piwik not archiving/not showing data

I switched from archiving in the browser to archiving via cron. I didn’t notice for a while that the cron didn’t work – I really thought I didn’t have any visitors :disappointed_relieved: – until I noticed that there were lot’s of visitors in fact.

Now I fixed the cron and ran everything I could think of:
php console core:archive --url=https://domain.com [--force-all-websites --force-all-periods=2592000 --force-date-last-n=1000] more than once with all the force stuff and without.
I thought I could recreate the archive, which was not created, from the logs… but my visitor graphs still show 0!

Any tips on how I can get my data back (they are in the logs, but not in the archive). I really need them now.

What’s the output? Could you remove the square brackets from this command?

Hey Quba,
I didn’t actually have the brackets in the command, they are only there to show that I tried it with and without the part inside them.

But thanks for the hint with the output – I just noticed I missed out an error while reading through the log: I ran the script with the wrong permission while running it manually…

I ran it with sudo, now it worked!