[SOLVED]Blank Page after update from 1.0 to 1.1


(XSK8) #1

Hi everybody and Happy New Year!

Issue: After updating automatically i’ve a blank page. Seems that there is a problem with the database update - I got no message after this.

I already tryed to apply the patch for the login problem - no effect… :frowning:

Any idea how to solve the problem.
Greets Frank


(XSK8) #2

Hi, I downgraded to 1.1 and its runnig again.
Anyway I’d like to stay up to date and it would be great if there is a solution to this problem.

Unfortunatley I have no idea where to start… :frowning:


(vipsoft) #3

please refer to the patches in 301 Moved Permanently


(XSK8) #4

[quote=vipsoft]
please refer to the patches in 301 Moved Permanently
I already did! No effect.

To make it clear, There is no output at all - even not error messages. No html source code - nothing.

Sorry, can’t give more info atm. :frowning:


(vipsoft) #5

what php version?


(XSK8) #6

PHP Version 5.2.6-1+lenny9

System Linux server5 2.6.26-2-686 #1 SMP Thu Aug 19 03:44:10 UTC 2010 i686


(Fabian Becker) #7

Can you check whether disable_errors is On? If it’s Off and you have access to php.ini please turn it On. You can also check your error.log for errors and post them here.


(XSK8) #8

Hey THX 4 the support!
display_errors is On
If you need other info you may check here: http://www.webdesign-in-muenster.de/info.php


(Fabian Becker) #9

Can you please check the access.log/error.log from your webserver check for PHP error messages? When exactly do you get the blank screen? (Sign in - Piwik - shows a login form)


(vipsoft) #10

I’m debugging against 5.2.6 right now.


(XSK8) #11

@vipsoft: sounds like there is light at the end of the tunnel :wink:
@Fabian Becker: I downgraded the piwick back to 1.0 - thats why you see a loginscreen and this version still works perfect. Unfortunately I don’t have access to the errorlogs on this server, just the “normal” logfiles.


(XSK8) #12

Just to keep this up to date - I tryed 1.1.1 today on this server - still same problem.

After updating - absolutley no output…


(Matthieu Aubry) #13

XSK8, do you have any error in your apache error log ?

A white page means the webserver has some problems but errors are not displayed on the screen, but in your logs.


(Thomas Seifert) #14

Did you try the
Logout, Clear Browser Cache, Login again
routine?


(XSK8) #15

Hi Thomas, I don’t even have a logout button :wink:
Anyway I deleted all cookies and cleared the cache… still nothing but white emptynes :frowning:


(Fabian Becker) #16

XSK8, can you please try to answer all asked questions? Can you somehow get access to the error.log (maybe in the interface of your hosting provider)? Where are you hosting your Piwik installation?


(XSK8) #17

@Fabian: I already sent a support ticket to the provider (www.internet4ever.eu) - no respose yet.

I’ll post the info about the error log as soon as I have it :wink:


#18

message builtin Update 1.1 to1.1.1


Warning: unlink(H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/latest.zip) [function.unlink]: Permission denied in H:\HOME\Web-Projekte\openengine\projekt\piwik\plugins\CoreUpdater\Controller.php on line 110

Backtrace -->
#0 Piwik_ErrorHandler(2, unlink(H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/latest.zip) [function.unlink]: Permission denied, H:\HOME\Web-Projekte\openengine\projekt\piwik\plugins\CoreUpdater\Controller.php, 110, Array ([archive] => Piwik_Unzip_ZipArchive Object ([] => ZipArchive Object ([status] => 0,[statusSys] => 0,[numFiles] => 2230,[filename] => H:\HOME\Web-Projekte\openengine\projekt\piwik\tmp\latest\latest.zip,[comment] => ),[filename] => H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/latest.zip),[pathExtracted] => H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/,[archive_files] => Array ([0] => Array ([filename] => H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/piwik/,[stored_filename] => piwik/, => 0,[compressed_size] => 0,[mtime] => 1294199814,[index] => 0,[crc] => 0),[1] => Array ([filename] => H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/piwik/tmp/,[stored_filename] => piwik/tmp/,[siz…#1 unlink(H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/latest.zip) called at [H:\HOME\Web-Projekte\openengine\projekt\piwik\plugins\CoreUpdater\Controller.php:110]#2 Piwik_CoreUpdater_Controller->oneClick_Unpack() called at [H:\HOME\Web-Projekte\openengine\projekt\piwik\plugins\CoreUpdater\Controller.php:62]#3 Piwik_CoreUpdater_Controller->oneClickUpdate()#4 call_user_func_array(Array ([0] => Piwik_CoreUpdater_Controller Object ([] => ,[] => Array (),[] => Array (),[] => Array (),[] => CoreUpdater,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0),[pathPiwikZip] => H:\HOME\Web-Projekte\openengine\projekt\piwik/tmp/latest/latest.zip),[1] => oneClickUpdate), Array ()) called at [H:\HOME\Web-Projekte\openengine\projekt\piwik\core\FrontController.php:125]#5 Piwik_FrontController->dispatch() called at [H:\HOME\Web-Projekte\openengine\projekt\piwik\index.php:60]

Piwik # Quelloffene Webanalytik

Update wird von [piwik.org] runtergeladen

Update wird entpackt

Die entpackten Dateien werden überprüft

Ein Backup der Konfigurationsdatei wird in /config/global.ini.auto-backup-before-update.php erstellt

Die neueste Version wird installiert

Es wurde erfolgreich ein Update von Piwik durchgeführt!


Dashboard is empty.
Firebug shows following Javascript Errors:

missing } after property list
[Bei diesem Fehler anhalten] $(’#visitsLive label’).tooltip({track:true,delay:0,showURL:false,showBody:" - "
index…d688836 (Zeile 1322)
$ is not defined
[Bei diesem Fehler anhalten] $(document).ready(function() {
index…e=today (Zeile 82)
$ is not defined
[Bei diesem Fehler anhalten] $(document).ready(function() {
index…e=today (Zeile 106)
$ is not defined
[Bei diesem Fehler anhalten] $(document).ready(function() {
index…e=today (Zeile 201


(Fabian Becker) #19

machoyer, einmal ausloggen, browsercache leeren, neu einloggen, et voila


(XSK8) #20

Fianly got an info about the error logs but seems to be not very meaningful or helpful…

serverXYZ:/var/log/apache2# cat error.log | grep webdesign-in-muenster.de

[Sun Jan 02 07:41:27 2011] [client 95.108.158.233] File does not exist: /myserverpath/html/webdesign-in-muenster.de/robots.txt

[Sun Jan 02 12:20:52 2011] [client 89.244.101.196] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Mon Jan 03 08:18:21 2011] [client 174.129.228.67] File does not exist: /myserverpath/html/webdesign-in-muenster.de/robots.txt

[Mon Jan 03 08:37:42 2011] [client 95.108.158.233] File does not exist: /myserverpath/html/webdesign-in-muenster.de/robots.txt

[Mon Jan 03 11:01:24 2011] [client 89.244.122.16] File does not exist: / myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Mon Jan 03 18:28:40 2011] [client 89.244.102.76] File does not exist: / myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Mon Jan 03 21:05:06 2011] [client 89.244.122.16] File does not exist: / myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 10:43:07 2011] [client 95.108.158.233] File does not exist: /myserverpath/html/webdesign-in-muenster.de/robots.txt

[Tue Jan 04 13:05:31 2011] [client 89.244.97.97] File does not exist: myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 13:56:01 2011] [client 91.17.73.111] File does not exist: myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 13:56:24 2011] [client 91.17.73.111] File does not exist: myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 14:57:43 2011] [client 218.213.130.157] File does not exist: /myserverpath/html/webdesign-in-muenster.de/robots.txt

[Tue Jan 04 21:02:47 2011] [client 85.10.211.218] File does not exist: / myserverpath/html/webdesign-in-muenster.de/robots.txt

[Tue Jan 04 21:28:59 2011] [client 89.244.113.173] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 22:21:39 2011] [client 79.247.203.159] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 22:21:40 2011] [client 79.247.203.159] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 22:21:42 2011] [client 79.247.203.159] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 22:30:54 2011] [client 216.99.58.163] File does not exist: / myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Tue Jan 04 22:30:57 2011] [client 216.99.58.163] File does not exist: / myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Wed Jan 05 10:36:34 2011] [client 89.244.111.188] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Wed Jan 05 10:36:36 2011] [client 89.244.111.188] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Wed Jan 05 11:20:02 2011] [client 95.108.158.233] File does not exist: /myserverpath/html/webdesign-in-muenster.de/robots.txt

[Wed Jan 05 14:57:27 2011] [client 89.244.121.242] File does not exist: /myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Wed Jan 05 17:47:13 2011] [client 78.53.65.165] File does not exist: myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Wed Jan 05 17:47:13 2011] [client 78.53.65.165] File does not exist: myserverpath/html/webdesign-in-muenster.de/favicon.ico

[Wed Jan 05 17:47:16 2011] [client 78.53.65.165] File does not exist: myserverpath/html/webdesign-in-muenster.de/favicon.ico