SMTP Settings Webfaction


(jkeyes) #1

Hi,

This is my first post in the forum, please be gentle. I’ve tried searching for solutions to this but have come up short.

I’m trying to configure Piwik to use SMTP to send email. I have my Piwik installation hosted on Webfaction, and I have used their SMTP server successfully from WordPress.

I cannot get it to work with Piwik though. If I use port 465 the app becomes unresponsive. When I use port 25 I get the following error message:

Error: 5.7.1 : Client host rejected: Access denied Possible reason: your host may have disabled the mail() function. Please contact your Piwik administrator.

I have tried with each authentication method listed in the select, but the same error each time. I have confirmed that my username and password are correct.

Any ideas?

Thanks,
-John


(vipsoft) #2

Sorry, there’s a bug in Piwik 1.0 where it doesn’t use the authentication credentials. This is fixed in svn and will be in Piwik 1.1. (Real soon now.)


(jkeyes) #3

Okay, thanks for the update.


(jkeyes) #4

I upgraded to 1.1.1 today and can confirm the SMTP settings are now working.

The settings are:


[b]SMTP server address[/b]:            smtp.webfaction.com
[b]SMTP port[/b]:                      465
[b]Authentication method for SMTP[/b]: Login
[b]SMTP username:[/b]                  [i]<webfaction mailbox name>[/i]
[b]SMTP password:[/b]                  [i]<webfaction mailbox password>[/i]
[b]SMTP encryption:[/b]                SSL

Thanks for the fix.