"@@@SMARTY:TRIM:SCRIPT@@@" comes up all over the place


(harrym) #1

It’s driving me mad! Sometimes it goes away if I click settings, and then go back to the dashboard. Not usually though. I can’t find any reliable way to reproduce it. It breaks javascript (or maybe something else breaks javascript and makes it come up?) so I can’t switch sites or dates.

I’m using the bleeding edge version of piwik from /trunk, but I’ve gone through several versions and this problem has affected all of them.

Can anyone help? Any pointers would be helpful.

Screenshot:

[attachment=33:Screensh…_Firefox.png]


(vipsoft) #2

I have not seen this problem, which appears to be in a 3rd party library, i.e., libs/Smarty/plugins/outputfilter.trimwhitespace.php

Can you check your server’s error logs?

Try removing the tmp folder and recreating it with the correct permissions.


(harrym) #3

[quote=vipsoft @ Apr 27 2009, 06:58 PM]I have not seen this problem, which appears to be in a 3rd party library, i.e., libs/Smarty/plugins/outputfilter.trimwhitespace.php

Can you check your server’s error logs?

Try removing the tmp folder and recreating it with the correct permissions.[/quote]

There’s nothing in the log. Remade tmp but no joy. Anything else come to mind?


(vipsoft) #4

[deleted]


(vipsoft) #5

Just Google’d and spotted these:

Try removing some unused widgets from your dashboard or using the patch proposed in the first post or disable the filter in core/View.php:

//     $this->smarty->load_filter('output','trimwhitespace');