Since 2.8.0 RC1 --- The Piwik URL does not seem to be pointing to a Piwik server


#1

Hello,

nothing changed in server setup, worked great before, then I upgraded to Piwik 2.8.0 RC1 and the cron isn’t running anymore with following error:

INFO CoreConsole[2014-10-24 12:22:26] [622ae] ---------------------------
INFO CoreConsole[2014-10-24 12:22:26] [622ae] INIT
INFO CoreConsole[2014-10-24 12:22:26] [622ae] Piwik is installed at: https://example.com/_stats/index.php
INFO CoreConsole[2014-10-24 12:22:26] [622ae] Running Piwik 2.8.3 as Super User
ERROR CoreConsole[2014-10-24 12:22:27] [622ae] The Piwik URL https://example.com/_stats/index.php does not seem to be pointing to a Piwik server. Response was ’ 404 Not Found

Not Found

The requested URL /_stats/index.php was not found on this server.

'.

The only “strange” thing I see is, that the “requested URL” points to /_stats/index.php which is not the full path on the server, or it’s missing the domain name.

I have found some similar problems regarding the error message here in the forum, but none of them helped. And like I said, nothing changed in the server setup, just updated Piwik.
Now I am running latest Piwik 2.8.3 and the same problem. Any ideas?

Edit: Forgot to say, I am trying to run archiving:


 /usr/bin/php -f /var/www/vhosts/example/httpdocs/_stats/console core:archive --force-all-websites --force-all-periods=315576000 --force-date-last-n=1000 --url=https://example.com/_stats/


(Matthieu Aubry) #2

try over HTTP instead of HTTPS maybe? also check the URL returns the piwik login form


#3

Piwik works normally, just archiving gives me this error, http or https, same.
And like said, it worked before very well.
I was hoping, someone knows if they were changes regarding archiving in 2.8 RC1 and where I could take a look.