SFP reject from mail sent by piwik forum


(Pedro Estevão) #1

Hello,

I didn’t received any email from piwik forum by some time and seems to me a little strange as I used to received some by day. In order to check why I try make login. Forgot my password andmade many attemps to recover it by the link near login form and never received any email. More strange even.

As I have access to our mail access logs I try to check the reason why the emails doesn’t arrive to my inbox. The reason is that your SPF record is wrong:

spf-reject: HELO(mailhost.discoursehosting.com) from 37.34.62.4. MAILFROM:piwik+verp-938f27673601025de955f5095a73fa7d@discoursemail.com

Investigate further and in for exemple SPF Policy Tester with 37.34.62.4 and piwik@discoursemail.com in IP and sender it gave a softfail which some server may pass but ours because of intensive SPAM is blocking.

I think you must correct this because some other user may experience this issue. In the past - don’t know how many ago - it used to work fine and I remenber to receive your emails with xxx@forum.piwik.org if I remenber it right.

Maybe something in your hosting company or configurations have changed…

Greetings,

Pedro


(Lukas Winkler) #2

Hi,

We changed hosting a few weeks ago, so that’s definitely the reason.

I’ll forward the issue, many thanks for looking into the reason.


(Matthieu Aubry) #3

Thanks for the report, we have contacted the forums admins to ask about this issue and how we could fix this in the future. I’ll post again when we have some updates!


(Matthieu Aubry) #4

Hi @pestevao we have some changes in the Forum email configuration, which should have fixed the issue. Could you please try again and let us know if you now receive the email notifications as expected? Thanks,


(Pedro Estevão) #5

Hello @matthieu ,

No the messages continues to beeing rejected with softfail as described. The headers are almost the same:

spf-reject: HELO(mailhost.discoursehosting.com) from 37.34.62.4. MAILFROM:piwik+verp-871a753599ec66f99cee54dd3e1d2bfd@discoursemail.com

I think that the question is not on the forum side but on the SPF TXT record in your ISP domain (discoursemail.com) that is not allowing the IP 37.34.62.4 to send messages in its name.

Full SPF record:

v=spf1 mx ptr ip4:64.71.168.192/26 ip6:2001:470:1:3a8::/64 ip6:2001:470:aa::/48 ip4:216.218.240.120/29 ip6:2001:470:1:669::/64 ip6:2001:470:107::/48 ~all

And it gaves a softfail as in the end it have ~all if it was a -all a hardfail will be displayed.

Pedro


(Matthieu Aubry) #6

Hi Pedro,

Host has made some changes on the configuration, does it maybe work better now? Thanks for confirming


(Pedro Estevão) #7

Hi Matthieu,

Everything working fine right now! :slight_smile:

SPF record at spf.discoursehosting.com designates 37.34.62.4 as permitted sender

I’m glad to help.

Thank you, Pedro