Setting Up Cron

I am trying to set up cron auto-archiving and have setup the command line as follows:

/usr/local/bin/php -f /home/blssco5/public_html/piwik/console core:archive --url=https://www.blss.com/piwik/ > /home/blssco5/piwik-archive-output.log

Still using piwik as directory my web site is www.blss.com.

After doing this the report still says For optimal performance and a speedy Matomo, it is highly recommended to set up a crontab to automatically archive your reports, and to disable browser triggering in the Matomo settings. Learn more..

Also how do I eliminate this error message:
shell_exec
You need to enable this built-in function.
set_time_limit
mail
parse_ini_file
glob
gzopen
md5_file.

Thanks.

Hi,

Have you checked the output of the cronjob (/home/blssco5/piwik-archive-output.log)?

You might have disabled these functions via the disable_functions line in your php.ini config file of your PHP setup.