Server 500 error - possibly due nginx move

Hello all,
I’ve started encountering a server 500 error after using piwik for a few moths trouble free. The main and most recent change is a move to nginx from litespeed.
I had previously configured piwik to use geoip with apache/litespeed.
Nginx has been compiled with geoip.
I’ve also re-uploaded piwik and updated the config file and can’t resolve the 500 error.
Any ideas ?

Look in server error log ?

Nothing revealing in sever log Matt. However, it would seem that this is most likely due to an improper nginx config. I’ll get this resolved. Please close.

OK, I’ve realised that my configuration is actually an nginx+apache setup (I was previously just apache / litespeed) so nginx is a proxy handling static objects and backing the rest of to apache, so piwik should be working as is. It was working prior to the change over, however I had not checked for a few days.

I don’t see any error_log entries so any ideas again Matt as to what could be causing this ?

I also tried switching back to stock apache and it made no difference ?

I also tried a fresh install of piwik and copied over the config file and still the same result ??

nisiwi, I had the same problem. Here is my solution posted here.,102448

Thanks quark.

With my environment I’ll try 755 and see what happens.

That did it (:P)
Thanks again quark…didn’t think to try that simple solution!!

That’s great! I’m glad it worked. Do you know how to file a bug? This will help the Dev’s become aware of the problem.

Yes, probably badly written, however here it is;

Ok, great! It is actually changing the file permissions from 664 to 644, but I’m sure the Dev’s will know exactly what to do!