"Seiten-URL nicht definiert" nach Umstellung auf HTTPS


#1

Hallo,

im Forum wurde das Thema ja schon öfter beschrieben - für mich allerdings ohne Lösung. Wer kann helfen?

Wir haben eine PIWIK-Installtion (seit einigen Jahren) die immer aktuell gehalten wird. Enthalten sind über 100 Seiten. Nachdem wir mitbekommen haben, dass HTTPS-Seiten nicht getrackt werden, haben wir dem PIWIK ein Zertifikat verpasst, sodass nun alles unter HTTPS läuft. Seit dem werden die URLs aber nicht mehr ausgelesen. Dort steht dann nur “Seiten-URL nicht definiert”. Hat jemand eine Lösung für das Problem?

Gruß,
Jan


Seiten-URL nicht definiert - 2018
Seiten URL nicht definiert - Shopware https / http
(Stefan Giehl) #2

Werden die Seiten generell nicht mehr erkannt oder nur unter der Auflistung der Seiten?
Stehen im Besucher-Log noch die korrekten URLs die von den Besuchern besucht wurden?


#3

Hallo,

die Seiten werden generell nicht mehr erkannt.

Nein, im Besucher-Log stehen nur die Seitentitel, aber nicht URL´s.

Gruß,
Jan


(Stefan Giehl) #4

Ist euer Piwik dann über HTTP gar nicht mehr erreichbar?

Das ist jetzt nur mal ein Schuss ins Blaue, aber schau doch mal bitte in die Tabelle piwik_option. Dort gibt es einen Eintrag piwikUrl. Steht dort die Piwik-URL noch mit http?


#5

Hallo,

nein, die URL ist auch per HTTP erreichbar (springt von HTTP auf HTTPS um). In der Tabelle piwik_option steht unter piwikUrl die URL mit HTTPS. In der config.ini.php sind unter trusted_hosts auch beide URL´s eingetragen.

Gruß,
Jan


(Stefan Giehl) #6

Kannst du mir mal eine URL geben die getrackt werden sollte? Dann schau ich mal kurz über das Tracking-Cookie und das was an Piwik gesendet wird drüber.


#7

Hallo,

z.B. die Seite hier: http://www.sm-sportgeraete.de/

Viele Grüße,
Jan


(Stefan Giehl) #8

Ok. Ich denke ich weiß woran es liegt.
Der Aufruf von Piwik mit HTTP macht einen Redirect auf HTTPs. Dabei werden vom Browser die Parameter escaped.
Stell deine Tracking-Codes mal so um dass sie ausschließlich HTTPS verwenden und nicht abhängig vom aktuellen Protokoll.


#9

Volltreffer! Das war es. Habe den Trackingcode angepasst - nun klappts!

Vielen vielen Dank!

PS: Eigentlich ja auch einleuchtend - wenn man es weiß.


(Johann) #10

Hallo,

danke für die Fehlersuche.
Wie und wo kann ich die Tracking-Codes umstellen?

danke
johann