Segmente seit Matomo 3.12 defekt?!

Hallo,

wir tracken eine Webseite mit einer recht großen Baumstruktur. Für die verschiendenen Redakteure haben wir knapp 200 Segmente eingerichtet, die fast alle nach dem Muster “Seiten-URL” - “Startet mit” - “https://domain.de/Haupt-Menü1/Unter-Menü1/…” eingerichtet sind. Nun habe ich festgestellt, dass in den Statistiken der Segmente seit dem Tag des Updates auf Matomo 3.12.0 andere URLs enthalten sind, die nicht dem Filter entsprechen z.B. https://domain.de/Haupt-Menü2/… Den Tag des Updates können wir nachvollziehen, da die Matomo-Version in das entsprechende Ansible-Skript eingecheckt wurde. Hat jemand auch dieses Problem? Hab ich irgendeinen Bug-Report übersehen? Hilft ein Update auf 3.13?

Viele Grüße
Mike

Matomo-Version: 3.12.0
MySQL-Version: 5.5.62-0+deb8u1
PHP-Version: 5.6.40-0+deb8u7

Hallo,

Hier ist die Diskussion dazu:

Hallo Lukas,

danke für den Link zur Diskussion. Uihjui… da haben die Entwickler wohl einen mittelgroßen Bock geschossen… Für uns ist die Lage genau wie es die Leute im Thread beschreiben. Die Nutzer unserer Segmente verstehen nicht, warum auf einmal mehr URLs sichtbar sind, obwohl explizit auf eine URL gefiltert wird. Aus meiner Sicht ist es ein Bug. Auch wenn die pre 3.12-Funktionalität aus Sicht der Entwickler falsch/defekt war, so hat sich doch die bisherige Arbeitsweise etabliert und wird offensichtlich weit verbreitet so genutzt. Ich hoffe die Entwickler korrigieren das Verhalten wieder und kommen eventuell zu einer Lösung bei der beide Varianten verfügbar sind.
So wie ich es verstehe, gibt es aktuell keine echte Alternative?!

Viele Grüße
Mike

@Pete_Trombone wie ich gelesen habe, hast du auch das beschrieben Problem. Wie gehst du aktuell damit um?

Kommen andere Nutzer auch nicht mit der Umstellung zurecht? Was sind eure Lösungsansätze?

Viele Grüße
Mike

Meine Lösung: PowerBI.

Viele Grüsse aus Helsinki,

Mikko