Scheduler: Error Missing parameter : displayFormat for task

After updating from V3 to V4, we are seeing the error:
Scheduler: Error Missing parameter : displayFormat for task

/usr/share/nginx/html/matomo/plugins/ScheduledReports/API.php(724): Warning - Invalid argument supplied for foreach() - Matomo 4.8.0 - Please report this message in the Matomo forums: (please do a search first as it might have been reported already)

Any easy way to update all the reports so they’re not throwing errors?

This sometimes occurs when going from Matomo 3 to Matomo 4 because Matomo 4 uses PhpMailer instead of Zend Mail.

One workaround is the following:
Try to send a test email from the Matomo application itself. If there are any errors, the output from the Console command should provide us with additional information to resolve the issue. The command to run would be as follows:

./console core:test-email where the email is your email.

There is a known issue with the default PHPMailer settings that prevents Matomo from sending emails through a Mail server that uses a Self-Signed certificate. If this is the cause of the issue, then you can follow the steps in this GitHub issue to the vendor/phpmailer/phpmailer/src/PHPMailer.php file:

Please note that you will need to apply these changes to the file in the phpmailer folder each time you perform an update to Matomo.

Thanks for the info! I tested sending an email from the console and it went through without any issue. Any other ideas about what it could be or could it still be related to the mailer even though the test went through?

I confirmed if I go to generate a new report, it does in fact get delivered. It appears their is a configuration change from previous Matomo versions that is causing the older reports to fail. Scheduler: Error Missing parameter : displayFormat for task. Can this field be updated through a SQL command?