Scheduled report emails have not worked since the 2.x upgrade


#1

I’ve seen a few references in the forum about other users not seeing emails either after the upgrade. There were some replies saying that “it’ll be fixed in the next release”, but I still have the issue with latest. Is anyone else seeing this issue? Was there a change to the email setup with the 2.x upgrade that I glossed over?

Thanks in advance, Allen


(Matthieu Aubry) #2

with 2.1 all emails should be sent and scheduled reports also. We fixed all known issues. Does it work for password recovery emails ?

also try setup" How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


#3

Yes, the password recovery emails work (after I figured out what was going on)… Does that indicate something wrong, or right?


(Matthieu Aubry) #4

it means emails are working at least so it’s good

did you setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


#5

I have set up a cron job and still not getting reports automatically.


#6

i can confirm this.
i run the archiv script by console

INFO [2014-03-10 17:00:39] [888d0] START
INFO [2014-03-10 17:00:40] [888d0] Archived website id = 1, period = day, Time elapsed: 0.430s
INFO [2014-03-10 17:00:40] [888d0] Skipped website id 1, already processed period reports in recent run, 14 min 6s ago, Time elapsed: 0.430s
INFO [2014-03-10 17:00:40] [888d0] Starting Piwik reports archiving…
INFO [2014-03-10 17:00:40] [888d0] Done archiving!
INFO [2014-03-10 17:00:40] [888d0] ---------------------------
INFO [2014-03-10 17:00:40] [888d0] SUMMARY
INFO [2014-03-10 17:00:40] [888d0] Total daily visits archived: 26
INFO [2014-03-10 17:00:40] [888d0] Archived today’s reports for 1 websites
INFO [2014-03-10 17:00:40] [888d0] Archived week/month/year for 0 websites
INFO [2014-03-10 17:00:40] [888d0] Skipped 0 websites: no new visit since the last script execution
INFO [2014-03-10 17:00:40] [888d0] Skipped 1 websites day archiving: existing daily reports are less than 10 seconds old
INFO [2014-03-10 17:00:40] [888d0] Skipped 0 websites week/month/year archiving: existing periods reports are less than 3600 seconds old
INFO [2014-03-10 17:00:40] [888d0] Total API requests: 1
INFO [2014-03-10 17:00:40] [888d0] done: 1/1 100%, 26 v, 1 wtoday, 0 wperiods, 1 req, 431 ms, no error
INFO [2014-03-10 17:00:40] [888d0] Time elapsed: 0.431s
INFO [2014-03-10 17:00:40] [888d0] ---------------------------
INFO [2014-03-10 17:00:40] [888d0] SCHEDULED TASKS
INFO [2014-03-10 17:00:40] [888d0] Starting Scheduled tasks…
INFO [2014-03-10 17:00:40] [888d0] No task to run
INFO [2014-03-10 17:00:40] [888d0] done
INFO [2014-03-10 17:00:40] [888d0] ---------------------------

it seems that everything works fine. but no mail is send to me. i tryed with some time. at database table piwik_report the column ts_last_send is still null


(Matthieu Aubry) #7

Using the following plugin you can find out when the next scheduledReports tasks will be sent: http://plugins.piwik.org/TasksTimetable


#8

This is what I get run I run the plugin… This doesn’t look “right” does it?

Scheduled Tasks

The following tasks are scheduled to be executed based on the current server time Tuesday 11 March 2014 00:28:20.
NAME DATE (SERVER TIME)

Piwik_CoreAdminHome.purgeOutdatedArchives Thursday 19 December 2013 00:00:27
(in -82 days 0 hours)

Piwik_PrivacyManager.deleteLogData Thursday 19 December 2013 00:00:27
(in -82 days 0 hours)

Piwik_PrivacyManager.deleteReportData Thursday 19 December 2013 00:00:27
(in -82 days 0 hours)

Piwik_CoreAdminHome.optimizeArchiveTable Thursday 19 December 2013 00:00:28
(in -82 days 0 hours)

Piwik_PDFReports_API.sendReport_1 Thursday 19 December 2013 08:00:51
(in -81 days 16 hours)

Piwik_UserCountry_GeoIPAutoUpdater.update Wednesday 1 January 2014 00:00:03
(in -69 days 0 hours)


(Matthieu Aubry) #9

Are you using Piwik 2.1.0 and the latest version of TaskTimetable plugin? if so please post a bug comment in this ticket: tasktime table plugin: shows only tasks from the past (instead of next) · Issue #4661 · matomo-org/matomo · GitHub


#10

everything works here, thats weird…


My profile at [wordpress[/url] [url=http://spiloghygge.dk/spil/1059/Candy_Crush.html]candy crush](http://profiles.wordpress.org/milandude)

#11

@matt Yes, it looks like I have the latest plugin (including the release the yesterday) and release 2.1.0… I’ll write something up. Thanks for the help.