S....L....O....W loading


(Ian Shere) #1

Oh my goodness - it’s gotten worse than working with an old XT computer on a dial up connection! Yes, I have quite a lot of sites in my account (well, at least compared to most I’m guessing). Perhaps 70-75 entries.

When I open up Matomo (and it happens during a refresh too) it will take at least 2 minutes to display the info. Then, annoyingly often, I get…

“Oops… there was a problem during the request. Maybe the server had a temporary issue, or maybe you requested a report with too much data. Please try again. If this error occurs repeatedly please contact your Matomo administrator for assistance.” Refreshing sometimes works, otherwise I get:

An error occurred
Mysqli prepare error: MySQL server has gone away

Do another refresh and:

WARNING: /home/wwwckde/public_html/piwik/libs/Zend/Db/Statement/Mysqli.php(105): Warning - Error while sending STMT_CLOSE packet. PID=48281 - Matomo 3.3.0 - Please report this message in the Matomo forums: https://forum.matomo.org (please do a search first as it might have been reported already)
×
WARNING: /home/wwwckde/public_html/piwik/libs/Zend/Db/Statement/Mysqli.php(105): Warning - Error while sending STMT_CLOSE packet. PID=47554 - Matomo 3.3.0 - Please report this message in the Matomo forums: https://forum.matomo.org (please do a search first as it might have been reported already)

(There’s a 3rd one but I can only add 2 links)

As I write, it’s “Loading websites…” We’ll see.

I’m on a fast connection (a speed test shows 160Mbps) so it’s not my connection. Frustrated as, when it loads, it’s a great service and is lightyears ahead of Google Analytics. I just need it to work.


(Lukas Winkler) #2

Hi,

Did you check if your database is working correctly.

MySQL server has gone away can be because PHP needed to wait for a long time for the MySQL server(How do I fix the error "Mysql Server has gone away"? - Analytics Platform - Matomo)

Warning - Error while sending STMT_CLOSE packet. PID=47554 also happens when PHP wan’t to connect to MySQL.


(Ian Shere) #3

Thanks Lucas - never thought it being MY SQL!! :slight_smile:

I checked and my settings are:

| max_allowed_packet | 268435456 |
| wait_timeout | 120 |


#4

perhaps is this a solution: Pen-Ultima: Piwik Oops… there was a problem during the request


(Lukas Winkler) #5

This helps in many cases, but when it takes a long time and then times out with an “Oops”, increasing the memory won’t help, because more memory doesn’t make anything faster.


(Ian Shere) #6

Still experiencing worse than snail like performance. Tried changing the account Matomo is on to PHP7. Made no difference to speed.

I only have about 80 sites being tracked, none with huge amounts of traffic (highest is 3000 unique IPs per month - most around 2-300). I really like it, but I just can’t spare the time waiting 5-6 minutes for it to render the stats every time I log in. I can’t even update it now - just times out every time.


(Fabian Dellwing) #7

Did you disable archiving on page load? If not, please do so and try again.


(Ian Shere) #8

Not archiving, but I did set old reports to delete after 180 days. However, an interesting thing happening when I started Matomo this morning. The speed has gone way up and I was able to update it. I can only assume it was due to the upgrade to PHP7, though why it did not work immediately yesterday when I upgraded I cannot say. I’ve heard that PHP7 is much faster, but have not done the upgrade to any live sites yet as I need to investigate what extensions will or won’t run under it. So, things are running much more smoothly this morning, and I can only recommend everyone fo the PHP7 upgrade where possible.