Reports for today will be processed at most every X seconds


#1

Does this time limit apply when reports are invalidated and archiving is “forced” for a particular site such as below?

As we make adjustments to custom reports and tracking logic then want to immediately reprocess logs to view updated reports I want to be sure this command will always update the data regardless of whether it’s been run in the last 10 seconds or 10 minutes:

./console core:invalidate-report-data --sites=2825 --dates=2018-06-11,2018-06-16
./console core:archive --force-idsites=2825
./console core:clear-caches

Thanks!


(Fabian Dellwing) #2

This should only apply to browser triggered archiving and not console triggered, I think?


#3

Thanks for the reply. The reason I’m asking is that it occasionally doesn’t appear work and we’re trying to get a reliable process in place. When it doesn’t work we drop the archive tables, but that’s a bit heavy handed.


(Peterbo) #4

The limit also applies for console archiving. Set the parameter --force-timeout-for-periods=1 (Desc: The current week/ current month/ current year will be processed at most every [seconds]. If not specified, defaults to 3600.) to archive independently of the last archiving process.


#5

Awesome! Thank you!

I never noticed this and occasionally would be pulling my hair out trying to figure out why the console commands don’t re-archive.

It would be awesome if the console command output something like “Re-archived 10s ago, quitting”, or something in bold, red that shows that no action is being taken.

You can’t really tell the difference in output when it skips archiving due to this setting or not.

Thanks again!


(Peterbo) #6

Actually, it does.

Look at the notes when archiving is executed:

INFO [2018-06-18 15:57:45] 31317  INIT
INFO [2018-06-18 15:57:45] 31317  Running Matomo 3.5.1 as Super User
INFO [2018-06-18 15:57:45] 31317  ---------------------------
INFO [2018-06-18 15:57:45] 31317  NOTES
INFO [2018-06-18 15:57:45] 31317  - Reports for today will be processed at most every 900 seconds. You can change this value in Matomo UI > Settings > General Settings.
INFO [2018-06-18 15:57:45] 31317  - Reports for the current week/month/year will be requested at most every 3600 seconds.
INFO [2018-06-18 15:57:45] 31317  - Archiving was last executed without error 8s ago
...
INFO [2018-06-18 16:00:13] 2378  Skipped website id 194, already done 2 min 48s ago, Time elapsed: 0.004s

And in Summary:

INFO [2018-06-18 16:00:13] 2378  - 1 skipped because existing daily reports are less than 900 seconds old


#7

Huh, well it must be something else then. We use the following and periodically we see it doesn’t re-archive

./console core:invalidate-report-data --sites=2825 --dates=2018-06-12,2018-06-18
./console core:archive --force-idsites=2825
./console core:clear-caches